CVE-2025-68480 Marshmallow has DoS in Schema.load(many)
Attackers can cause denial of service by sending moderately sized requests to Schema.load with many=True, consuming excessive CPU resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-68480?
CVE-2025-68480 is a medium-severity denial of service vulnerability in marshmallow-code marshmallow, published on 22 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Marshmallow is a lightweight library for converting complex objects to and from simple Python datatypes. In versions from 3.0.0rc1 to before 3.26.2 and from 4.0.0 to before 4.1.2, Schema.load(data, many=True) is vulnerable to denial of service attacks. A moderately sized request can consume a disproportionate amount of CPU time. This issue has been patched in version 3.26.2 and 4.1.2.
Weakness: CWE-405
Which versions are affected by CVE-2025-68480?
5 open source packages ship an affected version, including marshmallow.
| Package | Affected | Fixed in |
|---|---|---|
marshmallow PyPI | From 3.0.0rc1 | 3.26.2, 4.1.2 |
marshmallow PyPI | From 3.0.0rc1 | 3.26.2 |
marshmallow PyPI | From 3.0.0rc1 | 3.26.2 |
marshmallow PyPI | From 4.0.0 | 4.1.2 |
marshmallow PyPI | From 4.0.0 | 4.1.2 |
Linux distribution packages (9)
python-marshmallow SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 3.20.2-150400.9.10.1 |
python-marshmallow SUSE:Linux Enterprise Module for Public Cloud 15 SP5 | All versions | 3.20.2-150400.9.10.1 |
python-marshmallow SUSE:Linux Enterprise Module for Public Cloud 15 SP6 | All versions | 3.20.2-150400.9.10.1 |
python-marshmallow SUSE:Linux Enterprise Module for Public Cloud 15 SP7 | All versions | 3.20.2-150400.9.10.1 |
python-marshmallow SUSE:Linux Enterprise Server 16.0 | All versions | 3.20.2-160000.3.1 |
python-marshmallow SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 3.20.2-160000.3.1 |
python-marshmallow openSUSE:Leap 15.6 | All versions | 3.20.2-150400.9.10.1 |
python-marshmallow openSUSE:Leap 16.0 | All versions | 3.20.2-160000.3.1 |
python-marshmallow openSUSE:Tumbleweed | All versions | 3.26.2-1.1 |
How do I fix CVE-2025-68480?
Upgrade marshmallow to a fixed version for your release line: 3.26.2 or 4.1.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-68480 being exploited?
There is no known exploitation of CVE-2025-68480 in the wild and no public exploit code.
Sources
Also known as CLEANSTART-2026-QQ80550, CLEANSTART-2026-YO50975, DEBIAN-CVE-2025-68480, ECHO-a840-85c8-68ac, GHSA-428g-f7cq-pgp5, MINI-8cj4-22v7-jwf2 and 10 more.