# CVE-2025-68481: FastAPI Users Vulnerable to 1-click Account Takeover in Apps Using FastAPI SSO

> Attackers can perform login CSRF to take over victim accounts or force them into attacker sessions due to stateless OAuth state tokens.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Dec 2025
- **Updated:** 19 Dec 2025
- **Also known as:** GHSA-5j53-63w8-8625, PYSEC-2026-1363

## What is CVE-2025-68481?

CVE-2025-68481 is a medium-severity vulnerability in fastapi-users, published on 19 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

FastAPI Users allows users to quickly add a registration and authentication system to their FastAPI project. Prior to version 15.0.2, the OAuth login state tokens are completely stateless and carry no per-request entropy or any data that could link them to the session that initiated the OAuth flow. `generate_state_token()` is always called with an empty `state_data` dict, so the resulting JWT only contains the fixed audience claim plus an expiration timestamp. On callback, the library merely checks that the JWT verifies under `state_secret` and is unexpired; there is no attempt to match the state value to the browser that initiated the OAuth request, no correlation cookie, and no server-side cache. Any attacker can hit `/authorize`, capture the server-generated state, finish the upstream OAuth flow with their own provider account, and then trick a victim into loading `.../callback?code=<attacker_code>&state=<attacker_state>`. Because the state JWT is valid for any client for \~1 hour, the victim’s browser will complete the flow. This leads to login CSRF. Depending on the app’s logic, the login CSRF can lead to an account takeover of the victim account or to the victim user getting logged in to the attacker's account. Version 15.0.2 contains a patch for the issue.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-68481?

3 open source packages ship an affected version, including fastapi-users. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastapi-users` | PyPI | All versions | 15.0.2 |
| `fastapi-users` | PyPI | All versions | 15.0.2 |
| `fastapi-users` | PyPI | All versions | 15.0.2 |

Products: Fastapi-Users Project Fastapi Users.

## How do I fix CVE-2025-68481?

Upgrade fastapi-users to 15.0.2 or later.

## Is CVE-2025-68481 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68481 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68481 and fix it if it is affected.

What it is: CVE-2025-68481 is a medium-severity vulnerability in fastapi-users, published on 19 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68481 exists.

Affected packages and fixed versions:
- fastapi-users (PyPI): affected all versions; fixed in 15.0.2
- fastapi-users (PyPI): affected all versions; fixed in 15.0.2
- fastapi-users (PyPI): affected all versions; fixed in 15.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68481/ (Markdown: https://insights.sbomify.com/CVE-2025-68481/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68481
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68481
- OSV: https://osv.dev/vulnerability/CVE-2025-68481

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68481/
Summaries are generated and may contain mistakes; the official description above is the record.
