CVE-2025-68493 Apache Struts, Apache Struts: XXE vulnerability in outdated XWork component
An attacker can exploit an XML External Entity vulnerability in Apache Struts to read sensitive data or cause denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-68493?
CVE-2025-68493 is a high-severity vulnerability in Apache Struts, published on 11 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Missing XML Validation vulnerability in Apache Struts, Apache Struts.
This issue affects Apache Struts: from 2.0.0 before 2.2.1; Apache Struts: from 2.2.1 through 6.1.0.
Users are recommended to upgrade to version 6.1.1, which fixes the issue.
Which versions are affected by CVE-2025-68493?
10 open source packages ship an affected version, including org.apache.struts:struts2-core, com.opensymphony:xwork and org.apache.struts.xwork:xwork-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.struts:struts2-core Maven | From 2.0.0 to 2.3.37 | None |
org.apache.struts:struts2-core Maven | From 2.0.0 to 2.3.37 | None |
org.apache.struts:struts2-core Maven | From 2.5.0 to 2.5.33 | None |
org.apache.struts:struts2-core Maven | From 2.5.0 to 2.5.33 | None |
org.apache.struts:struts2-core Maven | From 6.0.0 | 6.1.1 |
org.apache.struts:struts2-core Maven | From 6.0.0 | 6.1.1 |
4 more packages
com.opensymphony:xwork Maven | From 2.0.0 | None |
com.opensymphony:xwork Maven | From 2.0.0 | None |
org.apache.struts.xwork:xwork-core Maven | From 2.2.1 | None |
org.apache.struts.xwork:xwork-core Maven | From 2.2.1 | None |
Products include Apache Struts.
How do I fix CVE-2025-68493?
Upgrade org.apache.struts:struts2-core to 6.1.1 or later.
Is CVE-2025-68493 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68493 exists.
Public exploit code: 1 Nuclei template and 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-qcfc-hmrc-59x7.