# CVE-2025-68493: Apache Struts, Apache Struts: XXE vulnerability in outdated XWork component

> An attacker can exploit an XML External Entity vulnerability in Apache Struts to read sensitive data or cause denial of service.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jan 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-qcfc-hmrc-59x7

## What is CVE-2025-68493?

CVE-2025-68493 is a high-severity vulnerability in Apache Struts, published on 11 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Missing XML Validation vulnerability in Apache Struts, Apache Struts.

This issue affects Apache Struts: from 2.0.0 before 2.2.1; Apache Struts: from 2.2.1 through 6.1.0.

Users are recommended to upgrade to version 6.1.1, which fixes the issue.

Weakness: CWE-112 (Missing XML Validation), CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2025-68493?

10 open source packages ship an affected version, including org.apache.struts:struts2-core, com.opensymphony:xwork and org.apache.struts.xwork:xwork-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 to 2.3.37 | None |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 to 2.3.37 | None |
| `org.apache.struts:struts2-core` | Maven | From 2.5.0 to 2.5.33 | None |
| `org.apache.struts:struts2-core` | Maven | From 2.5.0 to 2.5.33 | None |
| `org.apache.struts:struts2-core` | Maven | From 6.0.0 | 6.1.1 |
| `org.apache.struts:struts2-core` | Maven | From 6.0.0 | 6.1.1 |
| `com.opensymphony:xwork` | Maven | From 2.0.0 | None |
| `com.opensymphony:xwork` | Maven | From 2.0.0 | None |
| `org.apache.struts.xwork:xwork-core` | Maven | From 2.2.1 | None |
| `org.apache.struts.xwork:xwork-core` | Maven | From 2.2.1 | None |

Products: Apache Struts.

## How do I fix CVE-2025-68493?

Upgrade org.apache.struts:struts2-core to 6.1.1 or later.

## Is CVE-2025-68493 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68493 exists.

Public exploit code:

- CVE-2025-68493 (github_poc): https://github.com/hsltz/CVE-2025-68493
- Apache Struts XWork - XML External Entity Injection (nuclei): http/cves/2025/CVE-2025-68493.yaml

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68493 and fix it if it is affected.

What it is: CVE-2025-68493 is a high-severity vulnerability in Apache Struts, published on 11 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68493 exists.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.0.0 up to 2.3.37; no fix listed
- org.apache.struts:struts2-core (Maven): affected from 2.0.0 up to 2.3.37; no fix listed
- org.apache.struts:struts2-core (Maven): affected from 2.5.0 up to 2.5.33; no fix listed
- org.apache.struts:struts2-core (Maven): affected from 2.5.0 up to 2.5.33; no fix listed
- org.apache.struts:struts2-core (Maven): affected from 6.0.0; fixed in 6.1.1
- org.apache.struts:struts2-core (Maven): affected from 6.0.0; fixed in 6.1.1
- com.opensymphony:xwork (Maven): affected from 2.0.0; no fix listed
- com.opensymphony:xwork (Maven): affected from 2.0.0; no fix listed
- org.apache.struts.xwork:xwork-core (Maven): affected from 2.2.1; no fix listed
- org.apache.struts.xwork:xwork-core (Maven): affected from 2.2.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68493/ (Markdown: https://insights.sbomify.com/CVE-2025-68493/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68493
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68493
- OSV: https://osv.dev/vulnerability/CVE-2025-68493

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68493/
Summaries are generated and may contain mistakes; the official description above is the record.
