CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources

Exploited in the wild Critical 10.0 Published Updated

Authenticated attackers can execute arbitrary code via expression injection in n8n, leading to full system compromise.

Exploited in the wild
Since 11 Mar 2026
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-68613?

CVE-2025-68613 is a critical code injection vulnerability in N8n N8n, published on 19 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

n8n is an open source workflow automation platform. Versions starting with 0.211.0 and prior to 1.120.4, 1.121.1, and 1.122.0 contain a critical Remote Code Execution (RCE) vulnerability in their workflow expression evaluation system. Under certain conditions, expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime. An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations. This issue has been fixed in versions 1.120.4, 1.121.1, and 1.122.0. Users are strongly advised to upgrade to a patched version, which introduces additional safeguards to restrict expression evaluation. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only; and/or deploy n8n in a hardened environment with restricted operating system privileges and network access to reduce the impact of potential exploitation. These workarounds do not fully eliminate the risk and should only be used as short-term measures.

Weakness: CWE-913

Which versions are affected by CVE-2025-68613?

4 open source packages ship an affected version, including n8n. It affects 1 product.

PackageAffectedFixed in
n8n npmFrom 0.211.01.120.4
n8n npmFrom 0.211.01.120.4
n8n npmFrom 1.121.01.121.1
n8n npmFrom 1.121.01.121.1

Products include N8n N8n.

How do I fix CVE-2025-68613?

Upgrade n8n to a fixed version for your release line: 1.120.4 or 1.121.1. US federal agencies must fix it by 25 Mar 2026.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-68613 being exploited?

Yes. Attackers have exploited CVE-2025-68613 in the wild since at least 11 Mar 2026.

Public exploit code: 1 Metasploit module, 1 Nuclei template and 37 proofs of concept on GitHub.

All N8n N8n vulnerabilities

Sources

Also known as GHSA-v98v-ff95-f3cp, ROOT-APP-NPM-CVE-2025-68613.

Is CVE-2025-68613 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free