# CVE-2025-68613: n8n Improper Control of Dynamically-Managed Code Resources

> Authenticated attackers can execute arbitrary code via expression injection in n8n, leading to full system compromise.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 11 Mar 2026 (CISA KEV)
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2025
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-v98v-ff95-f3cp, ROOT-APP-NPM-CVE-2025-68613

## What is CVE-2025-68613?

CVE-2025-68613 is a critical code injection vulnerability in N8n N8n, published on 19 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Versions starting with 0.211.0 and prior to 1.120.4, 1.121.1, and 1.122.0 contain a critical Remote Code Execution (RCE) vulnerability in their workflow expression evaluation system. Under certain conditions, expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime. An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations. This issue has been fixed in versions 1.120.4, 1.121.1, and 1.122.0. Users are strongly advised to upgrade to a patched version, which introduces additional safeguards to restrict expression evaluation. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only; and/or deploy n8n in a hardened environment with restricted operating system privileges and network access to reduce the impact of potential exploitation. These workarounds do not fully eliminate the risk and should only be used as short-term measures.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources)

## Which versions are affected by CVE-2025-68613?

4 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | From 0.211.0 | 1.120.4 |
| `n8n` | npm | From 0.211.0 | 1.120.4 |
| `n8n` | npm | From 1.121.0 | 1.121.1 |
| `n8n` | npm | From 1.121.0 | 1.121.1 |

Products: N8n N8n.

## How do I fix CVE-2025-68613?

Upgrade n8n to a fixed version for your release line: 1.120.4 or 1.121.1. US federal agencies must fix it by 25 Mar 2026.

## Is CVE-2025-68613 being exploited?

Yes. Attackers have exploited CVE-2025-68613 in the wild since at least 11 Mar 2026.

Public exploit code:

- CVE-2025-68613: n8n RCE vulnerability exploit and documentation (github_poc): https://github.com/wioui/n8n-CVE-2025-68613-exploit
- 🛡️ Official AI Security Tool module for CVE-2026-21858 + CVE-2025-68613 (n8n "Ni8mare" Unauthenticated Arbitrary File Read & Expression Injection RCE Full Chain). (github_poc): https://github.com/ZeroDayEvil/CVE-2026-21858-n8n-FullChain
- Public PoC + Scanner and research for CVE-2025-68613: Critical RCE in n8n Workflow Automation via Expression Injection (CVSS 10.0). Includes detection tools, full exploit, and remediation guidance. (github_poc): https://github.com/TheStingR/CVE-2025-68613-POC
- Detection for CVE-2025-68613 (github_poc): https://github.com/rxerium/CVE-2025-68613
- This laboratory provides a controlled environment to analyze and reproduce CVE-2025-68613 in a vulnerable n8n instance. (github_poc): https://github.com/LingerANR/n8n-CVE-2025-68613
- n8n God Mode Ultimate - CVE-2025-68613 Scanner v1.0.0         ║ ║           Workflow Automation Remote Code Execution    (github_poc): https://github.com/hackersatyamrastogi/n8n-exploit-CVE-2025-68613-n8n-God-Mode-Ultimate

## Other vulnerabilities in N8n N8n

- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)
- [CVE-2026-27493](https://insights.sbomify.com/CVE-2026-27493/): n8n has Unauthenticated Expression Evaluation via Form Node (critical 9.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68613 and fix it if it is affected.

What it is: CVE-2025-68613 is a critical code injection vulnerability in N8n N8n, published on 19 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2025-68613 in the wild since at least 11 Mar 2026.

Affected packages and fixed versions:
- n8n (npm): affected from 0.211.0; fixed in 1.120.4
- n8n (npm): affected from 0.211.0; fixed in 1.120.4
- n8n (npm): affected from 1.121.0; fixed in 1.121.1
- n8n (npm): affected from 1.121.0; fixed in 1.121.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68613/ (Markdown: https://insights.sbomify.com/CVE-2025-68613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68613
- OSV: https://osv.dev/vulnerability/CVE-2025-68613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68613/
Summaries are generated and may contain mistakes; the official description above is the record.
