# CVE-2025-68614: LibreNMS Alert Rule API Cross-Site Scripting Vulnerability

> Attackers can inject malicious scripts via unsanitized alert rule names in the LibreNMS API, potentially compromising user sessions.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Dec 2025
- **Updated:** 22 Dec 2025
- **Also known as:** GHSA-c89f-8g7g-59wj

## What is CVE-2025-68614?

CVE-2025-68614 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 22 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.12.0, the Alert Rule API is vulnerable to stored cross-site scripting. Alert rules can be created or updated via LibreNMS API. The alert rule name is not properly sanitized, and can be used to inject HTML code. This issue has been patched in version 25.12.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-68614?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 25.12.0 |
| `librenms/librenms` | Packagist | All versions | 25.12.0 |

Products: Librenms Librenms.

## How do I fix CVE-2025-68614?

Upgrade librenms/librenms to 25.12.0 or later.

## Is CVE-2025-68614 being exploited?

There is no known exploitation of CVE-2025-68614 in the wild and no public exploit code.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68614 and fix it if it is affected.

What it is: CVE-2025-68614 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 22 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-68614 in the wild and no public exploit code.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 25.12.0
- librenms/librenms (Packagist): affected all versions; fixed in 25.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68614/ (Markdown: https://insights.sbomify.com/CVE-2025-68614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68614
- OSV: https://osv.dev/vulnerability/CVE-2025-68614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68614/
Summaries are generated and may contain mistakes; the official description above is the record.
