CVE-2025-68615 Net-SNMP snmptrapd crash

Critical 9.8 Published Updated

A specially crafted packet sent to the Net-SNMP snmptrapd daemon causes a buffer overflow and crash, resulting in denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-68615?

CVE-2025-68615 is a critical memory corruption vulnerability in Debian Debian Linux, published on 22 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.

Weakness: CWE-119

Which versions are affected by CVE-2025-68615?

It affects 2 products.

Linux distribution packages (40)
net-snmp AlmaLinux:10All versions1:5.9.4-15.el10_1.2
net-snmp-agent-libs AlmaLinux:10All versions1:5.9.4-15.el10_1.2
net-snmp-devel AlmaLinux:10All versions1:5.9.4-15.el10_1.2
net-snmp-libs AlmaLinux:10All versions1:5.9.4-15.el10_1.2
net-snmp-perl AlmaLinux:10All versions1:5.9.4-15.el10_1.2
net-snmp-perl-module AlmaLinux:10All versions1:5.9.4-15.el10_1.2
net-snmp-utils AlmaLinux:10All versions1:5.9.4-15.el10_1.2
python3-net-snmp AlmaLinux:10All versions1:5.9.4-15.el10_1.2
net-snmp AlmaLinux:8All versions1:5.8-33.el8_10
net-snmp-agent-libs AlmaLinux:8All versions1:5.8-33.el8_10
net-snmp-devel AlmaLinux:8All versions1:5.8-33.el8_10
net-snmp-libs AlmaLinux:8All versions1:5.8-33.el8_10
net-snmp-perl AlmaLinux:8All versions1:5.8-33.el8_10
net-snmp-utils AlmaLinux:8All versions1:5.8-33.el8_10
net-snmp AlmaLinux:9All versions1:5.9.1-17.el9_7.1
net-snmp-agent-libs AlmaLinux:9All versions1:5.9.1-17.el9_7.1
net-snmp-devel AlmaLinux:9All versions1:5.9.1-17.el9_7.1
net-snmp-libs AlmaLinux:9All versions1:5.9.1-17.el9_7.1
net-snmp-perl AlmaLinux:9All versions1:5.9.1-17.el9_7.1
net-snmp-utils AlmaLinux:9All versions1:5.9.1-17.el9_7.1
python3-net-snmp AlmaLinux:9All versions1:5.9.1-17.el9_7.1
net-snmp Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
net-snmp-agent-libs Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
net-snmp-agent-libs-debuginfo Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
net-snmp-debuginfo Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
net-snmp-debugsource Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
net-snmp-devel Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
net-snmp-libs Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
net-snmp-libs-debuginfo Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
net-snmp-perl Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
net-snmp-perl-module Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
net-snmp-perl-module-debuginfo Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
net-snmp-utils Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
net-snmp-utils-debuginfo Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
python3-net-snmp Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
python3-net-snmp-debuginfo Red Hat:enterprise_linux:10.1All versions1:5.9.4-15.el10_1.2
net-snmp Red Hat:enterprise_linux:8::appstreamAll versions1:5.8-33.el8_10
net-snmp-agent-libs Red Hat:enterprise_linux:8::appstreamAll versions1:5.8-33.el8_10
net-snmp-agent-libs-debuginfo Red Hat:enterprise_linux:8::appstreamAll versions1:5.8-33.el8_10
net-snmp-debuginfo Red Hat:enterprise_linux:8::appstreamAll versions1:5.8-33.el8_10

Products include Debian Debian Linux, Net-Snmp Net-Snmp.

How do I fix CVE-2025-68615?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-68615 being exploited?

There is no known exploitation of CVE-2025-68615 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2025-68615, ALSA-2026:0668, ALSA-2026:0696, ALSA-2026:0750, AZL-72901, AZL-73175 and 46 more.

Is CVE-2025-68615 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free