CVE-2025-68617 Use after free in fluidsynth

High 7.0 Published Updated

A race condition in FluidSynth during DLS file unloading can cause a use-after-free, potentially leading to code execution or crashes.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-68617?

CVE-2025-68617 is a high-severity use after free vulnerability in fluidsynth, published on 23 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

FluidSynth is a software synthesizer based on the SoundFont 2 specifications. From versions 2.5.0 to before 2.5.2, a race condition during unloading of a DLS file can trigger a heap-based use-after-free. A concurrently running thread may be pending to unload a DLS file, leading to use of freed memory, if the synthesizer is being concurrently destroyed, or samples of the (unloaded) DLS file are concurrently used to synthesize audio. This issue has been patched in version 2.5.2. The problem will not occur, when explicitly unloading a DLS file (before synth destruction), provided that at the time of unloading, no samples of the respective file are used by active voices. The problem will not occur in versions of FluidSynth that have been compiled without native DLS support.

Weakness: CWE-416

Which versions are affected by CVE-2025-68617?

It affects 1 product.

Linux distribution packages (1)
fluidsynth openSUSE:TumbleweedAll versions2.5.2-1.1

Products include Fluidsynth Fluidsynth.

How do I fix CVE-2025-68617?

Upgrade to a fixed version.

Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.

Is CVE-2025-68617 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68617 exists.

Sources

Also known as DEBIAN-CVE-2025-68617, GHSA-ffw2-xvvp-39ch, UBUNTU-CVE-2025-68617, openSUSE-SU-2026:10004-1.

Is CVE-2025-68617 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free