# CVE-2025-68622: Espressif ESP-IDF USB Host UVC Class Driver has a stack buffer overflow in UVC descriptor printing

> A malicious USB device can trigger a stack buffer overflow in the ESP-IDF UVC driver when descriptor printing is enabled, potentially allowing code execution.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** GHSA-g65h-9ggq-9827

## What is CVE-2025-68622?

CVE-2025-68622 is a medium-severity memory corruption vulnerability in espressif esp-usb, published on 12 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Espressif ESP-IDF USB Host UVC Class Driver allows video streaming from USB cameras. Prior to 2.4.0, a vulnerability in the esp-usb UVC host implementation allows a malicious USB Video Class (UVC) device to trigger a stack buffer overflow during configuration-descriptor parsing. When UVC configuration-descriptor printing is enabled, the host prints detailed descriptor information provided by the connected USB device. A specially crafted UVC descriptor may advertise an excessively large length. Because this value is not validated before being copied into a fixed-size stack buffer, an attacker can overflow the buffer and corrupt memory. This vulnerability is fixed in 2.4.0.

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2025-68622?

It affects 1 product.


Products: Espressif Usb Host Uvc Class Driver.

## How do I fix CVE-2025-68622?

No fix has been published for CVE-2025-68622 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-68622 being exploited?

There is no known exploitation of CVE-2025-68622 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68622 and fix it if it is affected.

What it is: CVE-2025-68622 is a medium-severity memory corruption vulnerability in espressif esp-usb, published on 12 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68622 in the wild and no public exploit code.

Affected product: espressif esp-usb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68622/ (Markdown: https://insights.sbomify.com/CVE-2025-68622/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68622
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68622
- OSV: https://osv.dev/vulnerability/CVE-2025-68622

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68622/
Summaries are generated and may contain mistakes; the official description above is the record.
