{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-68637 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-68637 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-68637 is a critical vulnerability in Apache Uniffle, published on 7 Jan 2026."},"fix_prompt":"Check this codebase for CVE-2025-68637 and fix it if it is affected.\n\nWhat it is: CVE-2025-68637 is a critical vulnerability in Apache Uniffle, published on 7 Jan 2026. \nExploitation: There is no known exploitation of CVE-2025-68637 in the wild and no public exploit code.\n\nAffected product: Apache Uniffle. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-68637/ (Markdown: https://insights.sbomify.com/CVE-2025-68637/index.md)","id":"CVE-2025-68637","markdown":"https://insights.sbomify.com/CVE-2025-68637/index.md","name":"CVE-2025-68637","record":{"aliases":["GHSA-36gx-mxh9-mx5r"],"analysis":null,"analysis_generated_by":null,"assigner":"apache","cpe":[{"product":"uniffle","vendor":"apache"}],"cvss":{"score":9.1,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-297","name":"Improper Validation of Certificate with Host Mismatch"}],"description":"The Uniffle HTTP client is configured to trust all SSL certificates and\n\ndisables hostname verification by default. This insecure configuration\nexposes all REST API communication between the Uniffle CLI/client and the\nUniffle Coordinator service to potential Man-in-the-Middle (MITM) attacks.\n\nThis issue affects all versions from before 0.10.0.\n\nUsers are recommended to upgrade to version 0.10.0, which fixes the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache Uniffle: Insecure SSL Configuration in Uniffle HTTP Client","id":"CVE-2025-68637","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"Missing authorization in n/a","id":"CVE-2025-68640"},"packages":[],"prev":{"headline":"Missing authorization in Mail Assure","id":"CVE-2025-68624"},"products":["Apache Uniffle"],"published":"2026-01-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-07","vendors":["Apache Software Foundation"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2025-68637/"}