# CVE-2025-68637: Apache Uniffle: Insecure SSL Configuration in Uniffle HTTP Client


- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 7 Jan 2026
- **Updated:** 7 Jan 2026
- **Also known as:** GHSA-36gx-mxh9-mx5r

## What is CVE-2025-68637?

CVE-2025-68637 is a critical vulnerability in Apache Uniffle, published on 7 Jan 2026. 

### Official description

The Uniffle HTTP client is configured to trust all SSL certificates and

disables hostname verification by default. This insecure configuration
exposes all REST API communication between the Uniffle CLI/client and the
Uniffle Coordinator service to potential Man-in-the-Middle (MITM) attacks.

This issue affects all versions from before 0.10.0.

Users are recommended to upgrade to version 0.10.0, which fixes the issue.

Weakness: CWE-297 (Improper Validation of Certificate with Host Mismatch)

## Which versions are affected by CVE-2025-68637?

It affects 1 product.


Products: Apache Uniffle.

## How do I fix CVE-2025-68637?

No fix has been published for CVE-2025-68637 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-68637 being exploited?

There is no known exploitation of CVE-2025-68637 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68637 and fix it if it is affected.

What it is: CVE-2025-68637 is a critical vulnerability in Apache Uniffle, published on 7 Jan 2026. 
Exploitation: There is no known exploitation of CVE-2025-68637 in the wild and no public exploit code.

Affected product: Apache Uniffle. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68637/ (Markdown: https://insights.sbomify.com/CVE-2025-68637/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68637
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68637
- OSV: https://osv.dev/vulnerability/CVE-2025-68637

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68637/
Summaries are generated and may contain mistakes; the official description above is the record.
