# CVE-2025-68658: Open Source Point of Sale (opensourcepos) Stored XSS in Configuration (Information) – Company Name field

> An authenticated user can inject malicious JavaScript into the Company Name field, which executes in other users' browsers when viewing completed sales.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 13 Jan 2026
- **Updated:** 14 Jan 2026
- **Also known as:** GHSA-32r8-8r9r-9chw

## What is CVE-2025-68658?

CVE-2025-68658 is a medium-severity cross-site scripting vulnerability in opensourcepos, published on 13 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Open Source Point of Sale (opensourcepos) is a web based point of sale application written in PHP using CodeIgniter framework. opensourcepos 3.4.0 and 3.4.1 has a stored XSS vulnerability exists in the Configuration (Information) functionality. An authenticated user with the permission “Configuration: Change OSPOS's Configuration” can inject a malicious JavaScript payload into the Company Name field when updating Information in Configuration. The malicious payload is stored and later triggered when a user accesses /sales/complete. First select Sales, and choose New Item to create an item, then click on Completed . Due to insufficient input validation and output encoding, the payload is rendered and executed in the user’s browser, resulting in a stored XSS vulnerability. This vulnerability is fixed in 3.4.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-68658?

It affects 1 product.


Products: Opensourcepos Open Source Point of Sale.

## How do I fix CVE-2025-68658?

No fix has been published for CVE-2025-68658 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-68658 being exploited?

There is no known exploitation of CVE-2025-68658 in the wild and no public exploit code.

## Other vulnerabilities in opensourcepos

- [CVE-2026-32888](https://insights.sbomify.com/CVE-2026-32888/): Open Source Point of Sale is Vulnerable to SQL Injection Through its Item Search Functionality (high 8.8)
- [CVE-2026-26746](https://insights.sbomify.com/CVE-2026-26746/): Path traversal in n/a (high 8.8)
- [CVE-2025-68434](https://insights.sbomify.com/CVE-2025-68434/): opensourcepos has Cross-Site Request Forgery vulnerability that leads to Unauthorized Administrator Creation (high 8.8)
- [CVE-2025-68147](https://insights.sbomify.com/CVE-2025-68147/): opensourcepos has a Cross-site Scripting vulnerability (high 8.1)
- [CVE-2025-63800](https://insights.sbomify.com/CVE-2025-63800/): Auth bypass in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68658 and fix it if it is affected.

What it is: CVE-2025-68658 is a medium-severity cross-site scripting vulnerability in opensourcepos, published on 13 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-68658 in the wild and no public exploit code.

Affected product: opensourcepos. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68658/ (Markdown: https://insights.sbomify.com/CVE-2025-68658/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68658
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68658
- OSV: https://osv.dev/vulnerability/CVE-2025-68658

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68658/
Summaries are generated and may contain mistakes; the official description above is the record.
