CVE-2025-68659 Discourse has DoS vulnerability in username change endpoint
Attackers can cause server resource exhaustion and degraded performance by sending large JSON payloads to the username change endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-68659?
CVE-2025-68659 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 28 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have an application level denial of service vulnerabilityin the username change functionality at try.discourse.org. The vulnerability allows attackers to cause noticeable server delays and resource exhaustion by sending large JSON payloads to the username preference endpoint PUT /u//preferences/username, resulting in degraded performance for other users and endpoints. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. No known workarounds are available.
Weakness: CWE-770
Which versions are affected by CVE-2025-68659?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | All versions | 3.5.4, 2025.11.2, 2025.12.1, 2026.1.0 |
Products include Discourse Discourse.
How do I fix CVE-2025-68659?
Upgrade discourse to a fixed version for your release line: 3.5.4, 2025.11.2, 2025.12.1 or 2026.1.0.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-68659 being exploited?
There is no known exploitation of CVE-2025-68659 in the wild and no public exploit code.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2025-68659, GHSA-rmp6-c9rq-6q7p.