CVE-2025-68660 Discourse AI Discover's continue conversation allows threat actor to impersonate user

Medium 5.3 Published Updated

Authenticated users can bypass access controls to access restricted AI personas and impersonate others, leading to unauthorized data disclosure and abuse.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-68660?

CVE-2025-68660 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 28 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0, an endpoint lets any authenticated user bypass the ai_discover_persona access controls and gain ongoing DM access to personas that may be wired to staff-only categories, RAG document sets, or automated tooling, enabling unauthorized data disclosure. Because the controller also accepts arbitrary user_id, an attacker can impersonate other accounts to trigger unwanted AI conversations on their behalf, generating confusing or abusive PM traffic. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. No known workarounds are available.

Weakness: CWE-863

Which versions are affected by CVE-2025-68660?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.5.4, 2025.11.2, 2025.12.1, 2026.1.0

Products include Discourse Discourse.

How do I fix CVE-2025-68660?

Upgrade discourse to a fixed version for your release line: 3.5.4, 2025.11.2, 2025.12.1 or 2026.1.0.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-68660 being exploited?

There is no known exploitation of CVE-2025-68660 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2025-68660, GHSA-mrvm-rprq-jqqh.

Is CVE-2025-68660 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free