CVE-2025-68662 FinalDestination hostname matching allows SSRF protection bypass

High 7.6 Published Updated

Attackers can bypass SSRF protections in Discourse via hostname validation flaws, potentially accessing internal resources.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-68662?

CVE-2025-68662 is a high-severity server-side request forgery vulnerability in Discourse Discourse, published on 28 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0, a hostname validation issue in FinalDestination could allow bypassing SSRF protections under certain conditions. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. No known workarounds are available.

Weakness: CWE-918

Which versions are affected by CVE-2025-68662?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.5.4, 2025.11.2, 2025.12.1, 2026.1.0

Products include Discourse Discourse.

How do I fix CVE-2025-68662?

Upgrade discourse to a fixed version for your release line: 3.5.4, 2025.11.2, 2025.12.1 or 2026.1.0.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2025-68662 being exploited?

There is no known exploitation of CVE-2025-68662 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2025-68662, GHSA-gcfp-rjfc-925c.

Is CVE-2025-68662 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free