# CVE-2025-68668: n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node

> Authenticated users can bypass the Pyodide sandbox in the Python Code Node to execute arbitrary commands on the host system.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Dec 2025
- **Updated:** 5 Jan 2026
- **Also known as:** GHSA-62r4-hw23-cc8v

## What is CVE-2025-68668?

CVE-2025-68668 is a critical code injection vulnerability in N8n N8n, published on 26 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. From version 1.0.0 to before 2.0.0, a sandbox bypass vulnerability exists in the Python Code Node that uses Pyodide. An authenticated user with permission to create or modify workflows can exploit this vulnerability to execute arbitrary commands on the host system running n8n, using the same privileges as the n8n process. This issue has been patched in version 2.0.0. Workarounds for this issue involve disabling the Code Node by setting the environment variable NODES_EXCLUDE: "[\"n8n-nodes-base.code\"]", disabling Python support in the Code node by setting the environment variable N8N_PYTHON_ENABLED=false, which was introduced in n8n version 1.104.0, and configuring n8n to use the task runner based Python sandbox via the N8N_RUNNERS_ENABLED and N8N_NATIVE_PYTHON_RUNNER environment variables.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2025-68668?

2 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | From 1.0.0 | 2.0.0 |
| `n8n` | npm | From 1.0.0 | 2.0.0 |

Products: N8n N8n.

## How do I fix CVE-2025-68668?

Upgrade n8n to 2.0.0 or later.

## Is CVE-2025-68668 being exploited?

There is no known exploitation of CVE-2025-68668 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2026-27493](https://insights.sbomify.com/CVE-2026-27493/): n8n has Unauthenticated Expression Evaluation via Form Node (critical 9.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68668 and fix it if it is affected.

What it is: CVE-2025-68668 is a critical code injection vulnerability in N8n N8n, published on 26 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68668 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected from 1.0.0; fixed in 2.0.0
- n8n (npm): affected from 1.0.0; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68668/ (Markdown: https://insights.sbomify.com/CVE-2025-68668/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68668
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68668
- OSV: https://osv.dev/vulnerability/CVE-2025-68668

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68668/
Summaries are generated and may contain mistakes; the official description above is the record.
