CVE-2025-68670 xrdp improperly checks bounds of domain string length, which leads to Stack-based Buffer Overflow
Remote attackers can execute arbitrary code on xrdp servers via a stack-based buffer overflow in domain string processing.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-68670?
CVE-2025-68670 is a critical memory corruption vulnerability in Debian Debian Linux, published on 27 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
xrdp is an open source RDP server. xrdp before v0.10.5 contains an unauthenticated stack-based buffer overflow vulnerability. The issue stems from improper bounds checking when processing user domain information during the connection sequence. If exploited, the vulnerability could allow remote attackers to execute arbitrary code on the target system. The vulnerability allows an attacker to overwrite the stack buffer and the return address, which could theoretically be used to redirect the execution flow. The impact of this vulnerability is lessened if a compiler flag has been used to build the xrdp executable with stack canary protection. If this is the case, a second vulnerability would need to be used to leak the stack canary value. Upgrade to version 0.10.5 to receive a patch. Additionally, do not rely on stack canary protection on production systems.
Which versions are affected by CVE-2025-68670?
It affects 2 products.
Linux distribution packages (16)
xrdp SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 0.9.13.1-150200.4.36.1 |
xrdp SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 0.9.13.1-150200.4.36.1 |
xrdp SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 0.9.13.1-150200.4.36.1 |
xrdp SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 0.9.13.1-150200.4.36.1 |
xrdp SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 0.9.13.1-150600.15.6.1 |
xrdp SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 0.9.10-3.22.1 |
xrdp SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 0.9.13.1-150200.4.36.1 |
xrdp SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 0.9.13.1-150200.4.36.1 |
xrdp SUSE:Linux Enterprise Server 15 SP6-LTSS | All versions | 0.9.13.1-150600.15.6.1 |
xrdp SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 0.9.10-3.22.1 |
xrdp SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 0.9.13.1-150200.4.36.1 |
xrdp SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 0.9.13.1-150200.4.36.1 |
xrdp SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | All versions | 0.9.13.1-150600.15.6.1 |
xrdp openSUSE:Leap 15.6 | All versions | 0.9.13.1-150600.15.6.1 |
xrdp openSUSE:Leap 16.0 | All versions | 0.9.26-bp160.2.1 |
xrdp openSUSE:Tumbleweed | All versions | 0.9.27-1.1 |
Products include Debian Debian Linux, Neutrinolabs Xrdp.
How do I fix CVE-2025-68670?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2025-68670 being exploited?
There is no known exploitation of CVE-2025-68670 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2025-68670, DLA-4464-1, DSA-6123-1, GHSA-rwvg-gp87-gh6f, MGASA-2026-0037, SUSE-SU-2026:0404-1 and 5 more.