# CVE-2025-68670: xrdp improperly checks bounds of domain string length, which leads to Stack-based Buffer Overflow

> Remote attackers can execute arbitrary code on xrdp servers via a stack-based buffer overflow in domain string processing.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2026
- **Updated:** 3 Feb 2026
- **Also known as:** DEBIAN-CVE-2025-68670, DLA-4464-1, DSA-6123-1, GHSA-rwvg-gp87-gh6f, MGASA-2026-0037, SUSE-SU-2026:0404-1, SUSE-SU-2026:0433-1, SUSE-SU-2026:0477-1, UBUNTU-CVE-2025-68670, openSUSE-SU-2026:10146-1, openSUSE-SU-2026:20167-1

## What is CVE-2025-68670?

CVE-2025-68670 is a critical memory corruption vulnerability in Debian Debian Linux, published on 27 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xrdp is an open source RDP server. xrdp before v0.10.5 contains an unauthenticated stack-based buffer overflow vulnerability. The issue stems from improper bounds checking when processing user domain information during the connection sequence. If exploited, the vulnerability could allow remote attackers to execute arbitrary code on the target system. The vulnerability allows an attacker to overwrite the stack buffer and the return address, which could theoretically be used to redirect the execution flow. The impact of this vulnerability is lessened if a compiler flag has been used to build the xrdp executable with stack canary protection. If this is the case, a second vulnerability would need to be used to leak the stack canary value. Upgrade to version 0.10.5 to receive a patch. Additionally, do not rely on stack canary protection on production systems.

Weakness: CWE-787 (Out-of-bounds Write), CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2025-68670?

It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xrdp` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 0.9.13.1-150200.4.36.1 |
| `xrdp` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 0.9.13.1-150200.4.36.1 |
| `xrdp` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 0.9.13.1-150200.4.36.1 |
| `xrdp` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 0.9.13.1-150200.4.36.1 |
| `xrdp` | SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 0.9.13.1-150600.15.6.1 |
| `xrdp` | SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 0.9.10-3.22.1 |
| `xrdp` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 0.9.13.1-150200.4.36.1 |
| `xrdp` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 0.9.13.1-150200.4.36.1 |
| `xrdp` | SUSE:Linux Enterprise Server 15 SP6-LTSS | All versions | 0.9.13.1-150600.15.6.1 |
| `xrdp` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 0.9.10-3.22.1 |
| `xrdp` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 0.9.13.1-150200.4.36.1 |
| `xrdp` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 0.9.13.1-150200.4.36.1 |
| `xrdp` | SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | All versions | 0.9.13.1-150600.15.6.1 |
| `xrdp` | openSUSE:Leap 15.6 | All versions | 0.9.13.1-150600.15.6.1 |
| `xrdp` | openSUSE:Leap 16.0 | All versions | 0.9.26-bp160.2.1 |
| `xrdp` | openSUSE:Tumbleweed | All versions | 0.9.27-1.1 |

Products: Debian Debian Linux, Neutrinolabs Xrdp.

## How do I fix CVE-2025-68670?

Upgrade to a fixed version.

## Is CVE-2025-68670 being exploited?

There is no known exploitation of CVE-2025-68670 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68670 and fix it if it is affected.

What it is: CVE-2025-68670 is a critical memory corruption vulnerability in Debian Debian Linux, published on 27 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68670 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68670/ (Markdown: https://insights.sbomify.com/CVE-2025-68670/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68670
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68670
- OSV: https://osv.dev/vulnerability/CVE-2025-68670

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68670/
Summaries are generated and may contain mistakes; the official description above is the record.
