# CVE-2025-68675: Apache Airflow: proxy credentials for various providers might leak in task logs

> Attackers can view proxy credentials in logs because sensitive fields were not masked by default in Apache Airflow.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jan 2026
- **Updated:** 24 Feb 2026
- **Also known as:** BIT-airflow-2025-68675, ECHO-32bb-7462-bbdf, GHSA-7c2f-r6gc-h92h, MINI-39hf-qfj5-ffm6, MINI-xcg9-j85v-56hx, PYSEC-2026-10, ROOT-APP-PYPI-CVE-2025-68675

## What is CVE-2025-68675?

CVE-2025-68675 is a high-severity vulnerability in Apache Airflow, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Airflow versions before 3.1.6, and 2.11.1 the proxies and proxy fields within a Connection may include proxy URLs containing embedded authentication information. These fields were not treated as sensitive by default and therefore were not automatically masked in log output. As a result, when such connections are rendered or printed to logs, proxy credentials embedded in these fields could be exposed.

Users are recommended to upgrade to 3.1.6 or later for Airflow 3, and 2.11.1 or later for Airflow 2 which fixes this issue

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2025-68675?

6 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.11.1 |
| `apache-airflow` | PyPI | All versions | 2.11.1 |
| `apache-airflow` | PyPI | All versions | 3.1.6 |
| `apache-airflow` | PyPI | From 3.0.0b1 | 3.1.6 |
| `apache-airflow` | PyPI | From 3.0.0b1 | 3.1.6 |
| `airflow` | Bitnami | All versions | 3.1.6 |

Products: Apache Airflow.

## How do I fix CVE-2025-68675?

Upgrade apache-airflow to a fixed version for your release line: 2.11.1 or 3.1.6.

## Is CVE-2025-68675 being exploited?

There is no known exploitation of CVE-2025-68675 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68675 and fix it if it is affected.

What it is: CVE-2025-68675 is a high-severity vulnerability in Apache Airflow, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68675 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.11.1
- apache-airflow (PyPI): affected all versions; fixed in 2.11.1
- apache-airflow (PyPI): affected all versions; fixed in 3.1.6
- apache-airflow (PyPI): affected from 3.0.0b1; fixed in 3.1.6
- apache-airflow (PyPI): affected from 3.0.0b1; fixed in 3.1.6
- airflow (Bitnami): affected all versions; fixed in 3.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68675/ (Markdown: https://insights.sbomify.com/CVE-2025-68675/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68675
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68675
- OSV: https://osv.dev/vulnerability/CVE-2025-68675

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68675/
Summaries are generated and may contain mistakes; the official description above is the record.
