{"answers":{"affected":"2 open source packages ship an affected version, including httparty. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68696 exists.","fix":"Upgrade httparty to 0.24.0 or later.","what":"CVE-2025-68696 is a high-severity server-side request forgery vulnerability in jnunemaker httparty, published on 23 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-68696 and fix it if it is affected.\n\nWhat it is: CVE-2025-68696 is a high-severity server-side request forgery vulnerability in jnunemaker httparty, published on 23 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68696 exists.\n\nAffected packages and fixed versions:\n- httparty (RubyGems): affected all versions; fixed in 0.24.0\n- httparty (RubyGems): affected all versions; fixed in 0.24.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-68696/ (Markdown: https://insights.sbomify.com/CVE-2025-68696/index.md)","id":"CVE-2025-68696","markdown":"https://insights.sbomify.com/CVE-2025-68696/index.md","name":"CVE-2025-68696","record":{"aliases":["DEBIAN-CVE-2025-68696","GHSA-hm5p-x4rq-38w4","UBUNTU-CVE-2025-68696"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby HTTP client library","requires_auth":"none","summary":"An SSRF vulnerability in the httparty Ruby library allows attackers to leak API keys and access internal servers.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"httparty","vendor":"jnunemaker"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"httparty is an API tool. In versions 0.23.2 and prior, httparty is vulnerable to SSRF. This issue can pose a risk of leaking API keys, and it can also allow third parties to issue requests to internal servers. This issue has been patched via commit 0529bcd.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"httparty Has Potential SSRF Vulnerability That Leads to API Key Leakage","id":"CVE-2025-68696","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Self-hosted n8n has Legacy Code node that enables arbitrary file read/write","id":"CVE-2025-68697"},"packages":[{"ecosystem":"RubyGems","fixed":["0.24.0"],"introduced":["0"],"last_affected":[],"package":"httparty","purl":null,"source":"GHSA-hm5p-x4rq-38w4"},{"ecosystem":"RubyGems","fixed":["0.24.0"],"introduced":["0"],"last_affected":[],"package":"httparty","purl":"pkg:gem/httparty","source":"GHSA-hm5p-x4rq-38w4"}],"prev":{"headline":"Not used","id":"CVE-2025-68695"},"products":["httparty"],"published":"2025-12-23","related":[{"cvss_score":7.5,"headline":"HTTParty does not restrict casts of string values","id":"CVE-2013-1801","kev_date_added":null,"published":"2013-04-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-24","vendors":["jnunemaker"]},"summary":"An SSRF vulnerability in the httparty Ruby library allows attackers to leak API keys and access internal servers.","url":"https://insights.sbomify.com/CVE-2025-68696/"}