# CVE-2025-68696: httparty Has Potential SSRF Vulnerability That Leads to API Key Leakage

> An SSRF vulnerability in the httparty Ruby library allows attackers to leak API keys and access internal servers.

- **Severity:** High 7.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Dec 2025
- **Updated:** 24 Dec 2025
- **Also known as:** DEBIAN-CVE-2025-68696, GHSA-hm5p-x4rq-38w4, UBUNTU-CVE-2025-68696

## What is CVE-2025-68696?

CVE-2025-68696 is a high-severity server-side request forgery vulnerability in jnunemaker httparty, published on 23 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

httparty is an API tool. In versions 0.23.2 and prior, httparty is vulnerable to SSRF. This issue can pose a risk of leaking API keys, and it can also allow third parties to issue requests to internal servers. This issue has been patched via commit 0529bcd.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-68696?

2 open source packages ship an affected version, including httparty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `httparty` | RubyGems | All versions | 0.24.0 |
| `httparty` | RubyGems | All versions | 0.24.0 |

Products: Jnunemaker Httparty.

## How do I fix CVE-2025-68696?

Upgrade httparty to 0.24.0 or later.

## Is CVE-2025-68696 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68696 exists.

## Other vulnerabilities in jnunemaker httparty

- [CVE-2013-1801](https://insights.sbomify.com/CVE-2013-1801/): HTTParty does not restrict casts of string values (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68696 and fix it if it is affected.

What it is: CVE-2025-68696 is a high-severity server-side request forgery vulnerability in jnunemaker httparty, published on 23 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68696 exists.

Affected packages and fixed versions:
- httparty (RubyGems): affected all versions; fixed in 0.24.0
- httparty (RubyGems): affected all versions; fixed in 0.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68696/ (Markdown: https://insights.sbomify.com/CVE-2025-68696/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68696
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68696
- OSV: https://osv.dev/vulnerability/CVE-2025-68696

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68696/
Summaries are generated and may contain mistakes; the official description above is the record.
