CVE-2025-68698 Jervis has an RSA PKCS#1 v1.5 Padding Vulnerability

High 8.7 Published Updated

Jervis library uses vulnerable RSA padding, allowing attackers to decrypt data or bypass security checks via Bleichenbacher attacks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-68698?

CVE-2025-68698 is a high-severity vulnerability in samrocketman jervis, published on 13 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Jervis is a library for Job DSL plugin scripts and shared Jenkins pipeline libraries. Prior to 2.2, Jervis uses PKCS1Encoding which is vulnerable to Bleichenbacher padding oracle attacks. Modern systems should use OAEP (Optimal Asymmetric Encryption Padding). This vulnerability is fixed in 2.2.

Weakness: CWE-327

Which versions are affected by CVE-2025-68698?

2 open source packages ship an affected version, including net.gleske:jervis. It affects 1 product.

PackageAffectedFixed in
net.gleske:jervis MavenAll versions2.2
net.gleske:jervis MavenAll versions2.2

Products include Samrocketman Jervis.

How do I fix CVE-2025-68698?

Upgrade net.gleske:jervis to 2.2 or later.

Is CVE-2025-68698 being exploited?

There is no known exploitation of CVE-2025-68698 in the wild and no public exploit code.

Sources

Also known as GHSA-mqw7-c5gg-xq97.

Is CVE-2025-68698 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free