{"answers":{"affected":"3 open source packages ship an affected version, including github.com/abhinavxd/libredesk. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68927 exists.","fix":"Upgrade github.com/abhinavxd/libredesk to 0.8.6-beta or later.","what":"CVE-2025-68927 is a high-severity cross-site scripting vulnerability in abhinavxd libredesk, published on 27 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-68927 and fix it if it is affected.\n\nWhat it is: CVE-2025-68927 is a high-severity cross-site scripting vulnerability in abhinavxd libredesk, published on 27 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68927 exists.\n\nAffected packages and fixed versions:\n- github.com/abhinavxd/libredesk (Go): affected all versions; no fix listed\n- github.com/abhinavxd/libredesk (Go): affected all versions; fixed in 0.8.6-beta\n- github.com/abhinavxd/libredesk (Go): affected all versions; fixed in 0.8.6-beta\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-68927/ (Markdown: https://insights.sbomify.com/CVE-2025-68927/index.md)","id":"CVE-2025-68927","markdown":"https://insights.sbomify.com/CVE-2025-68927/index.md","name":"CVE-2025-68927","record":{"aliases":["GHSA-wh6m-h6f4-rjf4","GO-2025-4243"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LibreDesk support desk","requires_auth":"none","summary":"Attackers can inject arbitrary HTML into contact notes, enabling phishing and UI redress attacks in LibreDesk.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"libredesk","vendor":"libredesk"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Libredesk is a self-hosted customer support desk. Prior to version 0.8.6-beta, LibreDesk is vulnerable to stored HTML injection in the contact notes feature. When adding notes via POST /api/v1/contacts/{id}/notes, the backend automatically wraps user input in \u003cp\u003e tags. However, by intercepting the request and removing the \u003cp\u003e tag, an attacker can inject arbitrary HTML elements such as forms and images, which are then stored and rendered without proper sanitization. This can lead to phishing, CSRF-style forced actions, and UI redress attacks. This issue has been patched in version 0.8.6-beta.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Improper Neutralization of HTML Tags in a Web Page in libredesk","id":"CVE-2025-68927","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Frappe CRM vulnerable to authenticated XSS via website field","id":"CVE-2025-68928"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/abhinavxd/libredesk","purl":"pkg:golang/github.com/abhinavxd/libredesk","source":"GO-2025-4243"},{"ecosystem":"Go","fixed":["0.8.6-beta"],"introduced":["0"],"last_affected":[],"package":"github.com/abhinavxd/libredesk","purl":null,"source":"GHSA-wh6m-h6f4-rjf4"},{"ecosystem":"Go","fixed":["0.8.6-beta"],"introduced":["0"],"last_affected":[],"package":"github.com/abhinavxd/libredesk","purl":"pkg:golang/github.com/abhinavxd/libredesk","source":"GHSA-wh6m-h6f4-rjf4"}],"prev":{"headline":"RustFS has a gRPC Hardcoded Token Authentication Bypass","id":"CVE-2025-68926"},"products":["libredesk"],"published":"2025-12-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-29","vendors":["abhinavxd"]},"summary":"Attackers can inject arbitrary HTML into contact notes, enabling phishing and UI redress attacks in LibreDesk.","url":"https://insights.sbomify.com/CVE-2025-68927/"}