CVE-2025-68933 Discourse non-admin moderators can exfiltrate private content via post ownership transfer
Non-admin moderators can exfiltrate private content by transferring post ownership in restricted areas if the ownership transfer feature is enabled.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-68933?
CVE-2025-68933 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 28 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0, non-admin moderators with the `moderators_change_post_ownership` setting enabled can change ownership of posts in private messages and restricted categories they cannot access, then export their data to view the content. This is a broken access control vulnerability affecting sites that grant moderators post ownership transfer permissions. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. The patch adds visibility checks for both the topic and posts before allowing ownership transfer. As a workaround, disable the `moderators_change_post_ownership` site setting to prevent non-admin moderators from using the post ownership transfer feature.
Weakness: CWE-863
Which versions are affected by CVE-2025-68933?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | All versions | 3.5.4, 2025.11.2, 2025.12.1, 2026.1.0 |
Products include Discourse Discourse.
How do I fix CVE-2025-68933?
Upgrade discourse to a fixed version for your release line: 3.5.4, 2025.11.2, 2025.12.1 or 2026.1.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-68933 being exploited?
There is no known exploitation of CVE-2025-68933 in the wild and no public exploit code.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2025-68933, GHSA-hpxv-mw7v-fqg2.