# CVE-2025-68933: Discourse non-admin moderators can exfiltrate private content via post ownership transfer

> Non-admin moderators can exfiltrate private content by transferring post ownership in restricted areas if the ownership transfer feature is enabled.

- **Severity:** Medium 6.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jan 2026
- **Updated:** 28 Jan 2026
- **Also known as:** BIT-discourse-2025-68933, GHSA-hpxv-mw7v-fqg2

## What is CVE-2025-68933?

CVE-2025-68933 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 28 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0, non-admin moderators with the `moderators_change_post_ownership` setting enabled can change ownership of posts in private messages and restricted categories they cannot access, then export their data to view the content. This is a broken access control vulnerability affecting sites that grant moderators post ownership transfer permissions. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. The patch adds visibility checks for both the topic and posts before allowing ownership transfer. As a workaround, disable the `moderators_change_post_ownership` site setting to prevent non-admin moderators from using the post ownership transfer feature.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-68933?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.5.4, 2025.11.2, 2025.12.1, 2026.1.0 |

Products: Discourse Discourse.

## How do I fix CVE-2025-68933?

Upgrade discourse to a fixed version for your release line: 3.5.4, 2025.11.2, 2025.12.1 or 2026.1.0.

## Is CVE-2025-68933 being exploited?

There is no known exploitation of CVE-2025-68933 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68933 and fix it if it is affected.

What it is: CVE-2025-68933 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 28 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-68933 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.5.4, 2025.11.2, 2025.12.1, 2026.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68933/ (Markdown: https://insights.sbomify.com/CVE-2025-68933/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68933
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68933
- OSV: https://osv.dev/vulnerability/CVE-2025-68933

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68933/
Summaries are generated and may contain mistakes; the official description above is the record.
