# CVE-2025-68950: Magick's failure to limit MVG mutual references forming a loop

> Attackers can cause a stack overflow and denial of service by providing MVG files with circular references to ImageMagick.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Dec 2025
- **Updated:** 30 Dec 2025
- **Also known as:** CLSA-2026-1771868375, CLSA-2026-1771951235, DEBIAN-CVE-2025-68950, ECHO-7abf-6014-4f67, GHSA-7rvh-xqp3-pr8j, JLSEC-2026-932, MINI-p9rh-8c2f-g5vm, UBUNTU-CVE-2025-68950

## What is CVE-2025-68950?

CVE-2025-68950 is a medium-severity denial of service vulnerability in Imagemagick Imagemagick, published on 30 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to version 7.1.2-12, Magick fails to check for circular references between two MVGs, leading to a stack overflow. This is a DoS vulnerability, and any situation that allows reading the mvg file will be affected. Version 7.1.2-12 fixes the issue.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2025-68950?

34 open source packages ship an affected version, including Magick.NET-Q16-AnyCPU, Magick.NET-Q16-HDRI-AnyCPU and Magick.NET-Q16-HDRI-OpenMP-arm64. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-HDRI-OpenMP-x64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-HDRI-OpenMP-x64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q8-OpenMP-x64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q8-OpenMP-x64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q8-x64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q8-x64` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.10.1 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.10.1 |

Products: Imagemagick Imagemagick.

## How do I fix CVE-2025-68950?

Upgrade Magick.NET-Q16-AnyCPU to 14.10.1 or later.

## Is CVE-2025-68950 being exploited?

There is no known exploitation of CVE-2025-68950 in the wild and no public exploit code.

## Other vulnerabilities in Imagemagick Imagemagick

- [CVE-2019-19952](https://insights.sbomify.com/CVE-2019-19952/): Use after free in n/a (critical 9.8)
- [CVE-2018-16328](https://insights.sbomify.com/CVE-2018-16328/): Null dereference in n/a (critical 9.8)
- [CVE-2018-16329](https://insights.sbomify.com/CVE-2018-16329/): Null dereference in n/a (critical 9.8)
- [CVE-2017-18210](https://insights.sbomify.com/CVE-2017-18210/): Null dereference in n/a (critical 9.8)
- [CVE-2017-14138](https://insights.sbomify.com/CVE-2017-14138/): Denial of service in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68950 and fix it if it is affected.

What it is: CVE-2025-68950 is a medium-severity denial of service vulnerability in Imagemagick Imagemagick, published on 30 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68950 in the wild and no public exploit code.

Affected packages and fixed versions:
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.10.1
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.10.1
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.10.1
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.10.1
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.10.1
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.10.1
- Magick.NET-Q16-HDRI-OpenMP-x64 (NuGet): affected all versions; fixed in 14.10.1
- Magick.NET-Q16-HDRI-OpenMP-x64 (NuGet): affected all versions; fixed in 14.10.1
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.10.1
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.10.1
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.10.1
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68950/ (Markdown: https://insights.sbomify.com/CVE-2025-68950/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68950
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68950
- OSV: https://osv.dev/vulnerability/CVE-2025-68950

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68950/
Summaries are generated and may contain mistakes; the official description above is the record.
