# CVE-2025-68953: Certain Frappe requests are vulnerable to Path Traversal

> Attackers can retrieve arbitrary files from the server due to insufficient input sanitization in Frappe web framework requests.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Jan 2026
- **Updated:** 6 Jan 2026
- **Also known as:** GHSA-xj39-3g4p-f46v

## What is CVE-2025-68953?

CVE-2025-68953 is a high-severity path traversal vulnerability in frappe, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Frappe is a full-stack web application framework. Versions 14.99.5 and below and 15.0.0 through 15.80.1 include requests that are vulnerable to path traversal attacks. Arbitrary files from the server could be retrieved due to a lack of proper sanitization on some requests. This issue is fixed in versions 14.99.6 and 15.88.1. To workaround, changing the setup to use a reverse proxy is recommended.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-68953?

It affects 1 product.


Products: Frappe Frappe.

## How do I fix CVE-2025-68953?

No fix has been published for CVE-2025-68953 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-68953 being exploited?

There is no known exploitation of CVE-2025-68953 in the wild and no public exploit code.

## Other vulnerabilities in frappe

- [CVE-2019-14965](https://insights.sbomify.com/CVE-2019-14965/): Code injection in n/a (critical 9.8)
- [CVE-2026-35614](https://insights.sbomify.com/CVE-2026-35614/): Frappe has a SQL injection in bulk_update (critical 9.3)
- [CVE-2026-31877](https://insights.sbomify.com/CVE-2026-31877/): Frappe SQL Injection due to improper field sanitization (critical 9.3)
- [CVE-2025-68929](https://insights.sbomify.com/CVE-2025-68929/): Frappe may be vulnerable remote code execution due to server-side template injection (critical 9.1)
- [CVE-2019-14966](https://insights.sbomify.com/CVE-2019-14966/): SQL injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68953 and fix it if it is affected.

What it is: CVE-2025-68953 is a high-severity path traversal vulnerability in frappe, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68953 in the wild and no public exploit code.

Affected product: frappe. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68953/ (Markdown: https://insights.sbomify.com/CVE-2025-68953/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68953
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68953
- OSV: https://osv.dev/vulnerability/CVE-2025-68953

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68953/
Summaries are generated and may contain mistakes; the official description above is the record.
