# CVE-2025-68954: Pterodactyl does not revoke SFTP access when server is deleted or permissions reduced


- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 6 Jan 2026
- **Updated:** 6 Jan 2026
- **Also known as:** GHSA-8c39-xppg-479c, GO-2026-4283

## What is CVE-2025-68954?

CVE-2025-68954 is a high-severity vulnerability in pterodactyl panel, published on 6 Jan 2026. 

### Official description

Pterodactyl is a free, open-source game server management panel. Versions 1.11.11 and below do not revoke active SFTP connections when a user is removed from a server instance or has their permissions changes with respect to file access over SFTP. This allows a user that was already connected to SFTP to remain connected and access files even after their permissions are revoked. A user must have been connected to SFTP at the time of their permissions being revoked in order for this vulnerability to be exploited. This issue is fixed in version 1.12.0.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-68954?

5 open source packages ship an affected version, including pterodactyl/panel and github.com/pterodactyl/wings. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pterodactyl/panel` | Packagist | All versions | 1.12.0 |
| `pterodactyl/panel` | Packagist | All versions | 1.12.0 |
| `github.com/pterodactyl/wings` | Go | All versions | 1.12.0 |
| `github.com/pterodactyl/wings` | Go | All versions | 1.12.0 |
| `github.com/pterodactyl/wings` | Go | All versions | 1.12.0 |

Products: Pterodactyl Panel, Pterodactyl Wings.

## How do I fix CVE-2025-68954?

Upgrade pterodactyl/panel to 1.12.0 or later.

## Is CVE-2025-68954 being exploited?

There is no known exploitation of CVE-2025-68954 in the wild and no public exploit code.

## Other vulnerabilities in pterodactyl panel

- [CVE-2026-26016](https://insights.sbomify.com/CVE-2026-26016/): Pterodactyl Panel Allows Cross-Node Server Configuration Disclosure via Remote API Missing Authorization (critical 9.2)
- [CVE-2021-41129](https://insights.sbomify.com/CVE-2021-41129/): Authentication bypass in Pterodactyl (high 8.1)
- [CVE-2019-1020002](https://insights.sbomify.com/CVE-2019-1020002/): Pterodactyl vulnerable to 2FA Sniffing (high 7.5)
- [CVE-2025-69197](https://insights.sbomify.com/CVE-2025-69197/): Pterodactyl TOTPs can be reused during validity window (medium 6.5)
- [CVE-2024-34067](https://insights.sbomify.com/CVE-2024-34067/): Multiple cross site scripting (XSS) vulnerabilities in the admin area of Pterodactyl panel (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68954 and fix it if it is affected.

What it is: CVE-2025-68954 is a high-severity vulnerability in pterodactyl panel, published on 6 Jan 2026. 
Exploitation: There is no known exploitation of CVE-2025-68954 in the wild and no public exploit code.

Affected packages and fixed versions:
- pterodactyl/panel (Packagist): affected all versions; fixed in 1.12.0
- pterodactyl/panel (Packagist): affected all versions; fixed in 1.12.0
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.12.0
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.12.0
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68954/ (Markdown: https://insights.sbomify.com/CVE-2025-68954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68954
- OSV: https://osv.dev/vulnerability/CVE-2025-68954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68954/
Summaries are generated and may contain mistakes; the official description above is the record.
