# CVE-2025-69196: FastMCP OAuth Proxy token reuse across MCP servers

> Attackers can reuse OAuth tokens across different MCP servers due to improper resource parameter handling in FastMCP.

- **Severity:** High 7.4 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Mar 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-5h2m-4q8j-pqpj, PYSEC-2026-2474, ROOT-APP-PYPI-CVE-2025-69196

## What is CVE-2025-69196?

CVE-2025-69196 is a high-severity authentication bypass vulnerability in jlowin fastmcp, published on 16 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

FastMCP is the standard framework for building MCP applications. Prior to version 2.14.2, the server does not properly respect the resource parameter submitted by the client in the authorization and token request. Instead of issuing the token explicitly for the MCP server, the token is issued for the base_url passed to the OAuthProxy during initialization. This issue has been patched 2.14.2.

Weakness: CWE-1220 (Insufficient Granularity of Access Control), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-69196?

3 open source packages ship an affected version, including fastmcp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastmcp` | PyPI | All versions | 2.14.2 |
| `fastmcp` | PyPI | All versions | 2.14.2 |
| `fastmcp` | PyPI | All versions | 2.14.2 |

Products: Jlowin Fastmcp.

## How do I fix CVE-2025-69196?

Upgrade fastmcp to 2.14.2 or later.

## Is CVE-2025-69196 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69196 exists.

## Other vulnerabilities in jlowin fastmcp

- [CVE-2026-32871](https://insights.sbomify.com/CVE-2026-32871/): FastMCP OpenAPI Provider has an SSRF & Path Traversal Vulnerability (critical 10.0)
- [CVE-2026-27124](https://insights.sbomify.com/CVE-2026-27124/): FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities (high 8.2)
- [CVE-2025-64340](https://insights.sbomify.com/CVE-2025-64340/): FastMCP has a Command Injection vulnerability - Gemini CLI (medium 6.7)
- [CVE-2025-62801](https://insights.sbomify.com/CVE-2025-62801/): FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name (medium 5.4)
- [CVE-2025-62800](https://insights.sbomify.com/CVE-2025-62800/): FastMCP vulnerable to reflected XSS in client's callback page (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69196 and fix it if it is affected.

What it is: CVE-2025-69196 is a high-severity authentication bypass vulnerability in jlowin fastmcp, published on 16 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69196 exists.

Affected packages and fixed versions:
- fastmcp (PyPI): affected all versions; fixed in 2.14.2
- fastmcp (PyPI): affected all versions; fixed in 2.14.2
- fastmcp (PyPI): affected all versions; fixed in 2.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69196/ (Markdown: https://insights.sbomify.com/CVE-2025-69196/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69196
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69196
- OSV: https://osv.dev/vulnerability/CVE-2025-69196

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69196/
Summaries are generated and may contain mistakes; the official description above is the record.
