# CVE-2025-69197: Pterodactyl TOTPs can be reused during validity window

> Attackers can reuse intercepted TOTP codes to bypass two-factor authentication and take over accounts in Pterodactyl panels.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jan 2026
- **Updated:** 6 Jan 2026
- **Also known as:** GHSA-rgmp-4873-r683

## What is CVE-2025-69197?

CVE-2025-69197 is a medium-severity authentication bypass vulnerability in pterodactyl panel, published on 6 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pterodactyl is a free, open-source game server management panel. Versions 1.11.11 and below allow TOTP to be used multiple times during its validity window. Users with 2FA enabled are prompted to enter a token during sign-in, and afterward it is not sufficiently marked as used in the system. This allows an attacker who intercepts that token to use it in addition to a known username/password during the 60-second token validity window. The attacker must have intercepted a valid 2FA token (for example, during a screen share). This issue is fixed in version 1.12.0.

Weakness: CWE-294 (Authentication Bypass by Capture-replay), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-69197?

2 open source packages ship an affected version, including pterodactyl/panel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pterodactyl/panel` | Packagist | All versions | 1.12.0 |
| `pterodactyl/panel` | Packagist | All versions | 1.12.0 |

Products: Pterodactyl Panel.

## How do I fix CVE-2025-69197?

Upgrade pterodactyl/panel to 1.12.0 or later.

## Is CVE-2025-69197 being exploited?

There is no known exploitation of CVE-2025-69197 in the wild and no public exploit code.

## Other vulnerabilities in pterodactyl panel

- [CVE-2026-26016](https://insights.sbomify.com/CVE-2026-26016/): Pterodactyl Panel Allows Cross-Node Server Configuration Disclosure via Remote API Missing Authorization (critical 9.2)
- [CVE-2021-41129](https://insights.sbomify.com/CVE-2021-41129/): Authentication bypass in Pterodactyl (high 8.1)
- [CVE-2025-68954](https://insights.sbomify.com/CVE-2025-68954/): Pterodactyl does not revoke SFTP access when server is deleted or permissions reduced (high 7.5)
- [CVE-2019-1020002](https://insights.sbomify.com/CVE-2019-1020002/): Pterodactyl vulnerable to 2FA Sniffing (high 7.5)
- [CVE-2024-34067](https://insights.sbomify.com/CVE-2024-34067/): Multiple cross site scripting (XSS) vulnerabilities in the admin area of Pterodactyl panel (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69197 and fix it if it is affected.

What it is: CVE-2025-69197 is a medium-severity authentication bypass vulnerability in pterodactyl panel, published on 6 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-69197 in the wild and no public exploit code.

Affected packages and fixed versions:
- pterodactyl/panel (Packagist): affected all versions; fixed in 1.12.0
- pterodactyl/panel (Packagist): affected all versions; fixed in 1.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69197/ (Markdown: https://insights.sbomify.com/CVE-2025-69197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69197
- OSV: https://osv.dev/vulnerability/CVE-2025-69197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69197/
Summaries are generated and may contain mistakes; the official description above is the record.
