# CVE-2025-69199: Pterodactyl websocket endpoints have no visible rate limits or monitoring, allowing for DOS attacks

> Attackers can exhaust system resources via unthrottled websocket connections in Pterodactyl Wings, causing denial of service.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2026
- **Updated:** 20 Jan 2026
- **Also known as:** GHSA-8w7m-w749-rx98, GO-2026-4331

## What is CVE-2025-69199?

CVE-2025-69199 is a high-severity denial of service vulnerability in pterodactyl panel, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Wings is the server control plane for Pterodactyl, a free, open-source game server management panel. Prior to version 1.12.0, websockets within wings lack proper rate limiting and throttling. As a result a malicious user can open a large number of connections and then request data through these sockets, causing an excessive volume of data over the network and overloading the host system memory and cpu. Additionally, there is not a limit applied to the total size of messages being sent or received, allowing a malicious user to open thousands of websocket connections and then send massive volumes of information over the socket, overloading the host network, and causing increased CPU and memory load within Wings. Version 1.12.0 patches the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-69199?

3 open source packages ship an affected version, including github.com/pterodactyl/wings. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pterodactyl/wings` | Go | All versions | 1.12.0 |
| `github.com/pterodactyl/wings` | Go | All versions | 1.12.0 |
| `github.com/pterodactyl/wings` | Go | All versions | 1.12.0 |

Products: Pterodactyl Wings.

## How do I fix CVE-2025-69199?

Upgrade github.com/pterodactyl/wings to 1.12.0 or later.

## Is CVE-2025-69199 being exploited?

There is no known exploitation of CVE-2025-69199 in the wild and no public exploit code.

## Other vulnerabilities in pterodactyl panel

- [CVE-2024-27102](https://insights.sbomify.com/CVE-2024-27102/): Improper isolation of server file access in github.com/pterodactyl/wings (critical 10.0)
- [CVE-2023-25168](https://insights.sbomify.com/CVE-2023-25168/): Symbolic Link (Symlink) Following allowing the deletion of files and directories on the host system in wings (critical 9.6)
- [CVE-2023-32080](https://insights.sbomify.com/CVE-2023-32080/): Wings vulnerable to escape to host from installation container (critical 9.1)
- [CVE-2024-34066](https://insights.sbomify.com/CVE-2024-34066/): Arbitrary File Write/Read in Pterodactyl wings (high 8.5)
- [CVE-2023-25152](https://insights.sbomify.com/CVE-2023-25152/): Symbolic Link (Symlink) Following in github.com/pterodactyl/wings (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69199 and fix it if it is affected.

What it is: CVE-2025-69199 is a high-severity denial of service vulnerability in pterodactyl panel, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-69199 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.12.0
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.12.0
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69199/ (Markdown: https://insights.sbomify.com/CVE-2025-69199/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69199
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69199
- OSV: https://osv.dev/vulnerability/CVE-2025-69199

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69199/
Summaries are generated and may contain mistakes; the official description above is the record.
