{"answers":{"affected":"4 open source packages ship an affected version, including thorsten/phpmyfaq. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69200 exists.","fix":"Upgrade thorsten/phpmyfaq to 4.0.16 or later.","what":"CVE-2025-69200 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 29 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-69200 and fix it if it is affected.\n\nWhat it is: CVE-2025-69200 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 29 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69200 exists.\n\nAffected packages and fixed versions:\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.16\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.16\n- thorsten/phpmyfaq (Packagist): affected from 4.1.0-alpha up to 4.1.0-beta.2; no fix listed\n- thorsten/phpmyfaq (Packagist): affected from 4.1.0-alpha up to 4.1.0-beta.2; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-69200/ (Markdown: https://insights.sbomify.com/CVE-2025-69200/index.md)","id":"CVE-2025-69200","markdown":"https://insights.sbomify.com/CVE-2025-69200/index.md","name":"CVE-2025-69200","record":{"aliases":["GHSA-9cg9-4h4f-j6fg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyFAQ web application","requires_auth":"none","summary":"Unauthenticated attackers can download configuration backups containing database credentials, leading to information disclosure and potential system compromise.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"phpmyfaq","vendor":"phpmyfaq"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-202","name":"Exposure of Sensitive Information Through Data Queries"}],"description":"phpMyFAQ is an open source FAQ web application. In versions prior to 4.0.16, an unauthenticated remote attacker can trigger generation of a configuration backup ZIP via `POST /api/setup/backup` and then download the generated ZIP from a web-accessible location. The ZIP contains sensitive configuration files (e.g., `database.php` with database credentials), leading to high-impact information disclosure and potential follow-on compromise. Version 4.0.16 fixes the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2025/CVE-2025-69200.yaml","stars":null,"title":"phpMyFAQ - Configuration Backup Disclosure"}],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ has unauthenticated config backup download via /api/setup/backup","id":"CVE-2025-69200","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyfaq:phpmyfaq","products":["phpmyfaq:phpmyfaq"],"type":"information_disclosure","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"Tugtainer has RCE in Agent Command Execution Api","id":"CVE-2025-69201"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.16"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-9cg9-4h4f-j6fg"},{"ecosystem":"Packagist","fixed":["4.0.16"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-9cg9-4h4f-j6fg"},{"ecosystem":"Packagist","fixed":[],"introduced":["4.1.0-alpha"],"last_affected":["4.1.0-beta.2"],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-9cg9-4h4f-j6fg"},{"ecosystem":"Packagist","fixed":[],"introduced":["4.1.0-alpha"],"last_affected":["4.1.0-beta.2"],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-9cg9-4h4f-j6fg"}],"prev":{"headline":"Pterodactyl websocket endpoints have no visible rate limits or monitoring, allowing for DOS attacks","id":"CVE-2025-69199"},"products":["phpMyFAQ"],"published":"2025-12-29","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0310","kev_date_added":null,"published":"2023-01-15"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq","id":"CVE-2022-4407","kev_date_added":null,"published":"2022-12-11"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2017-11187","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle","id":"CVE-2026-76213","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge","id":"CVE-2026-76214","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq","id":"CVE-2023-5316","kev_date_added":null,"published":"2023-09-30"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0306","kev_date_added":null,"published":"2023-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-29","vendors":["thorsten"]},"summary":"Unauthenticated attackers can download configuration backups containing database credentials, leading to information disclosure and potential system compromise.","url":"https://insights.sbomify.com/CVE-2025-69200/"}