# CVE-2025-69202: axios-cache-interceptor Vulnerable to Cache Poisoning via Ignored HTTP Vary Header

> Server-side applications using this library may leak user data and bypass authorization by ignoring Vary headers, allowing cross-session cache poisoning.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Dec 2025
- **Updated:** 30 Dec 2025
- **Also known as:** GHSA-x4m5-4cw8-vc44

## What is CVE-2025-69202?

CVE-2025-69202 is a medium-severity authentication bypass vulnerability in arthurfiorette axios-cache-interceptor, published on 29 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Axios Cache Interceptor is a cache interceptor for axios. Prior to version 1.11.1, when a server calls an upstream service using different auth tokens, axios-cache-interceptor returns incorrect cached responses, leading to authorization bypass. The cache key is generated only from the URL, ignoring request headers like `Authorization`. When the server responds with `Vary: Authorization` (indicating the response varies by auth token), the library ignores this, causing all requests to share the same cache regardless of authorization. Server-side applications (APIs, proxies, backend services) that use axios-cache-interceptor to cache requests to upstream services, handle requests from multiple users with different auth tokens, and upstream services replies on `Vary` to differentiate caches are affected. Browser/client-side applications (single user per browser session) are not affected. Services using different auth tokens to call upstream services will return incorrect cached data, bypassing authorization checks and leaking user data across different authenticated sessions. After `v1.11.1`, automatic `Vary` header support is now enabled by default. When server responds with `Vary: Authorization`, cache keys now include the authorization header value. Each user gets their own cache.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-573 (Improper Following of Specification by Caller), CWE-524 (Use of Cache Containing Sensitive Information)

## Which versions are affected by CVE-2025-69202?

2 open source packages ship an affected version, including axios-cache-interceptor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios-cache-interceptor` | npm | All versions | 1.11.1 |
| `axios-cache-interceptor` | npm | All versions | 1.11.1 |

Products: Axios-Cache-Interceptor Axios Cache Interceptor.

## How do I fix CVE-2025-69202?

Upgrade axios-cache-interceptor to 1.11.1 or later.

## Is CVE-2025-69202 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69202 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69202 and fix it if it is affected.

What it is: CVE-2025-69202 is a medium-severity authentication bypass vulnerability in arthurfiorette axios-cache-interceptor, published on 29 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69202 exists.

Affected packages and fixed versions:
- axios-cache-interceptor (npm): affected all versions; fixed in 1.11.1
- axios-cache-interceptor (npm): affected all versions; fixed in 1.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69202/ (Markdown: https://insights.sbomify.com/CVE-2025-69202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69202
- OSV: https://osv.dev/vulnerability/CVE-2025-69202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69202/
Summaries are generated and may contain mistakes; the official description above is the record.
