# CVE-2025-69203: Signal K Server Vulnerable to Access Request Spoofing

> Attackers can spoof IP addresses and device names to trick administrators into granting elevated access permissions via social engineering.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jan 2026
- **Updated:** 2 Jan 2026
- **Also known as:** GHSA-vfrf-vcj7-wvr8

## What is CVE-2025-69203?

CVE-2025-69203 is a medium-severity authentication bypass vulnerability in signalk-server, published on 1 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Signal K Server is a server application that runs on a central hub in a boat. Versions prior to 2.19.0 of the access request system have two related features that when combined by themselves and with an information disclosure vulnerability enable convincing social engineering attacks against administrators. When a device creates an access request, it specifies three fields: `clientId`, `description`, and `permissions`. The SignalK admin UI displays the `description` field prominently to the administrator when showing pending requests, but the actual `permissions` field (which determines the access level granted) is less visible or displayed separately. This allows an attacker to request `admin` permissions while providing a description that suggests readonly access. The access request handler trusts the `X-Forwarded-For` HTTP header without validation to determine the client's IP address. This header is intended to preserve the original client IP when requests pass through reverse proxies, but when trusted unconditionally, it allows attackers to spoof their IP address. The spoofed IP is displayed to administrators in the access request approval interface, potentially making malicious requests appear to originate from trusted internal network addresses. Since device/source names can be enumerated via the information disclosure vulnerability, an attacker can impersonate a legitimate device or source, craft a convincing description, spoof a trusted internal IP address, and request elevated permissions, creating a highly convincing social engineering scenario that increases the likelihood of administrator approval. Users should upgrade to version 2.19.0 to fix this issue.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2025-69203?

2 open source packages ship an affected version, including signalk-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `signalk-server` | npm | All versions | 2.19.0 |
| `signalk-server` | npm | All versions | 2.19.0 |

Products: Signalk Signal K Server.

## How do I fix CVE-2025-69203?

Upgrade signalk-server to 2.19.0 or later.

## Is CVE-2025-69203 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69203 exists.

## Other vulnerabilities in signalk-server

- [CVE-2026-23515](https://insights.sbomify.com/CVE-2026-23515/): RCE - Command Injection in Signal K set-system-time plugin (critical 10.0)
- [CVE-2025-66398](https://insights.sbomify.com/CVE-2025-66398/): Signal K Server has Unauthenticated State Pollution leading to Remote Code Execution (RCE) (critical 9.7)
- [CVE-2026-33950](https://insights.sbomify.com/CVE-2026-33950/): signalk-server: Privilege Escalation by Admin Role Injection via /enableSecurity (critical 9.4)
- [CVE-2025-68620](https://insights.sbomify.com/CVE-2025-68620/): Signal K Server vulnerable to JWT Token Theft via WebSocket Enumeration and Unauthenticated Polling (critical 9.1)
- [CVE-2026-41893](https://insights.sbomify.com/CVE-2026-41893/): Signal K Server's WebSocket Login Endpoint Lacks Rate Limiting (Credential Brute-Force) (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69203 and fix it if it is affected.

What it is: CVE-2025-69203 is a medium-severity authentication bypass vulnerability in signalk-server, published on 1 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69203 exists.

Affected packages and fixed versions:
- signalk-server (npm): affected all versions; fixed in 2.19.0
- signalk-server (npm): affected all versions; fixed in 2.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69203/ (Markdown: https://insights.sbomify.com/CVE-2025-69203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69203
- OSV: https://osv.dev/vulnerability/CVE-2025-69203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69203/
Summaries are generated and may contain mistakes; the official description above is the record.
