CVE-2025-6921 Regular Expression Denial of Service (ReDoS) in huggingface/transformers

Medium 5.3 Published Updated

Attackers can cause denial of service in Hugging Face Transformers by supplying malicious regular expressions to the AdamWeightDecay optimizer.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-6921?

CVE-2025-6921 is a medium-severity denial of service vulnerability in huggingface/transformers, published on 23 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The huggingface/transformers library, versions prior to 4.53.0, is vulnerable to Regular Expression Denial of Service (ReDoS) in the AdamWeightDecay optimizer. The vulnerability arises from the _do_use_weight_decay method, which processes user-controlled regular expressions in the include_in_weight_decay and exclude_from_weight_decay lists. Malicious regular expressions can cause catastrophic backtracking during the re.search call, leading to 100% CPU utilization and a denial of service. This issue can be exploited by attackers who can control the patterns in these lists, potentially causing the machine learning task to hang and rendering services unresponsive.

Weakness: CWE-400

Which versions are affected by CVE-2025-6921?

3 open source packages ship an affected version, including transformers. It affects 1 product.

PackageAffectedFixed in
transformers PyPIAll versions4.53.0
transformers PyPIAll versions4.53.0
transformers PyPIAll versions4.53.0
Linux distribution packages (1)
python-transformers openSUSE:TumbleweedAll versions5.15.0-1.1

Products include Huggingface Transformers.

How do I fix CVE-2025-6921?

Upgrade transformers to 4.53.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-6921 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6921 exists.

Sources

Also known as GHSA-4w7r-h757-3r74, PYSEC-2026-1980, openSUSE-SU-2026:11499-1.

Is CVE-2025-6921 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free