# CVE-2025-6921: Regular Expression Denial of Service (ReDoS) in huggingface/transformers

> Attackers can cause denial of service in Hugging Face Transformers by supplying malicious regular expressions to the AdamWeightDecay optimizer.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2025
- **Updated:** 23 Sep 2025
- **Also known as:** GHSA-4w7r-h757-3r74, PYSEC-2026-1980, openSUSE-SU-2026:11499-1

## What is CVE-2025-6921?

CVE-2025-6921 is a medium-severity denial of service vulnerability in huggingface/transformers, published on 23 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The huggingface/transformers library, versions prior to 4.53.0, is vulnerable to Regular Expression Denial of Service (ReDoS) in the AdamWeightDecay optimizer. The vulnerability arises from the _do_use_weight_decay method, which processes user-controlled regular expressions in the include_in_weight_decay and exclude_from_weight_decay lists. Malicious regular expressions can cause catastrophic backtracking during the re.search call, leading to 100% CPU utilization and a denial of service. This issue can be exploited by attackers who can control the patterns in these lists, potentially causing the machine learning task to hang and rendering services unresponsive.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-6921?

3 open source packages ship an affected version, including transformers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `transformers` | PyPI | All versions | 4.53.0 |
| `transformers` | PyPI | All versions | 4.53.0 |
| `transformers` | PyPI | All versions | 4.53.0 |
| `python-transformers` | openSUSE:Tumbleweed | All versions | 5.15.0-1.1 |

Products: Huggingface Transformers.

## How do I fix CVE-2025-6921?

Upgrade transformers to 4.53.0 or later.

## Is CVE-2025-6921 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6921 exists.

## Other vulnerabilities in huggingface/transformers

- [CVE-2023-7018](https://insights.sbomify.com/CVE-2023-7018/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.6)
- [CVE-2023-6730](https://insights.sbomify.com/CVE-2023-6730/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.0)
- [CVE-2024-11393](https://insights.sbomify.com/CVE-2024-11393/): Hugging Face Transformers MaskFormer Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2024-11394](https://insights.sbomify.com/CVE-2024-11394/): Hugging Face Transformers Trax Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2026-5241](https://insights.sbomify.com/CVE-2026-5241/): Policy Bypass in LightGlue Nested Config Resolution in huggingface/transformers (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6921 and fix it if it is affected.

What it is: CVE-2025-6921 is a medium-severity denial of service vulnerability in huggingface/transformers, published on 23 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6921 exists.

Affected packages and fixed versions:
- transformers (PyPI): affected all versions; fixed in 4.53.0
- transformers (PyPI): affected all versions; fixed in 4.53.0
- transformers (PyPI): affected all versions; fixed in 4.53.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6921/ (Markdown: https://insights.sbomify.com/CVE-2025-6921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6921
- OSV: https://osv.dev/vulnerability/CVE-2025-6921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6921/
Summaries are generated and may contain mistakes; the official description above is the record.
