# CVE-2025-69210: FacturaScripts vulnerable to Stored Cross-Site Scripting (XSS) via XML File Upload

> Authenticated users can upload malicious XML files to execute JavaScript in admin browsers, enabling account takeover.

- **Severity:** Low 1.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Dec 2025
- **Updated:** 30 Dec 2025
- **Also known as:** GHSA-2267-xqcf-gw2m

## What is CVE-2025-69210?

CVE-2025-69210 is a low-severity cross-site scripting vulnerability in NeoRazorX facturascripts, published on 30 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

FacturaScripts is open-source enterprise resource planning and accounting software. Prior to version 2025.7, a stored cross-site scripting (XSS) vulnerability exists in the product file upload functionality. Authenticated users can upload crafted XML files containing executable JavaScript. These files are later rendered by the application without sufficient sanitization or content-type enforcement, allowing arbitrary JavaScript execution when the file is accessed. Because product files uploaded by regular users are visible to administrative users, this vulnerability can be leveraged to execute malicious JavaScript in an administrator’s browser session. Version 2025.7 fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-69210?

4 open source packages ship an affected version, including facturascripts/facturascripts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `facturascripts/facturascripts` | Packagist | All versions | None |
| `facturascripts/facturascripts` | Packagist | All versions | None |
| `facturascripts/facturascripts` | Packagist | All versions | 2025.7 |
| `facturascripts/facturascripts` | Packagist | All versions | 2025.7 |

Products: Facturascripts Facturascripts.

## How do I fix CVE-2025-69210?

Upgrade facturascripts/facturascripts to 2025.7 or later.

## Is CVE-2025-69210 being exploited?

There is no known exploitation of CVE-2025-69210 in the wild and no public exploit code.

Public exploit code:

- FacturaScripts 2025.43 - XSS (exploitdb)

## Other vulnerabilities in NeoRazorX facturascripts

- [CVE-2022-1571](https://insights.sbomify.com/CVE-2022-1571/): Cross-site scripting - Reflected in Create Subaccount in neorazorx/facturascripts (critical 9.9)
- [CVE-2022-1715](https://insights.sbomify.com/CVE-2022-1715/): Account Takeover in neorazorx/facturascripts (critical 9.8)
- [CVE-2022-1682](https://insights.sbomify.com/CVE-2022-1682/): Reflected Xss using url based payload in neorazorx/facturascripts (critical 9.4)
- [CVE-2022-1514](https://insights.sbomify.com/CVE-2022-1514/): Stored XSS via upload plugin functionality in zip format in neorazorx/facturascripts (critical 9.0)
- [CVE-2022-1457](https://insights.sbomify.com/CVE-2022-1457/): Store XSS in title parameter executing at EditUser Page & EditProducto page in neorazorx/facturascripts (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69210 and fix it if it is affected.

What it is: CVE-2025-69210 is a low-severity cross-site scripting vulnerability in NeoRazorX facturascripts, published on 30 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-69210 in the wild and no public exploit code.

Affected packages and fixed versions:
- facturascripts/facturascripts (Packagist): affected all versions; no fix listed
- facturascripts/facturascripts (Packagist): affected all versions; no fix listed
- facturascripts/facturascripts (Packagist): affected all versions; fixed in 2025.7
- facturascripts/facturascripts (Packagist): affected all versions; fixed in 2025.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69210/ (Markdown: https://insights.sbomify.com/CVE-2025-69210/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69210
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69210
- OSV: https://osv.dev/vulnerability/CVE-2025-69210

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69210/
Summaries are generated and may contain mistakes; the official description above is the record.
