# CVE-2025-69211: Nest has a Fastify URL Encoding Middleware Bypass (TOCTOU)

> Attackers can bypass security middleware in NestJS Fastify applications to access protected routes or administrative endpoints without proper authentication.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Dec 2025
- **Updated:** 29 Dec 2025
- **Also known as:** GHSA-8wpr-639p-ccrj

## What is CVE-2025-69211?

CVE-2025-69211 is a medium-severity authentication bypass vulnerability in nestjs nest, published on 29 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nest is a framework for building scalable Node.js server-side applications. Versions prior to 11.1.11 have a Fastify URL encoding middleware bypass. A NestJS application is vulnerable if it uses `@nestjs/platform-fastify`; relies on `NestMiddleware` (via `MiddlewareConsumer`) for security checks (authentication, authorization, etc.), or through `app.use()`; and applies middleware to specific routes using string paths or controllers (e.g., `.forRoutes('admin')`). Exploitation can result in unauthenticated users accessing protected routes, restricted administrative endpoints becoming accessible to lower-privileged users, and/or middleware performing sanitization or validation being skipped. This issue is patched in `@nestjs/platform-fastify@11.1.11`.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2025-69211?

2 open source packages ship an affected version, including @nestjs/platform-fastify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@nestjs/platform-fastify` | npm | All versions | 11.1.11 |
| `@nestjs/platform-fastify` | npm | All versions | 11.1.11 |

Products: Nestjs Nest.

## How do I fix CVE-2025-69211?

Upgrade @nestjs/platform-fastify to 11.1.11 or later.

## Is CVE-2025-69211 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69211 exists.

## Other vulnerabilities in nestjs nest

- [CVE-2026-33011](https://insights.sbomify.com/CVE-2026-33011/): Nest Fastify HEAD Request Middleware Bypass (high 8.7)
- [CVE-2026-2293](https://insights.sbomify.com/CVE-2026-2293/): NestJS 11.1.13 - Lack of data validation allowing authentication/authorization bypass (high 8.2)
- [CVE-2026-40879](https://insights.sbomify.com/CVE-2026-40879/): Nest: DoS via Recursive handleData in JsonSocket (TCP Transport) (high 7.5)
- [CVE-2026-35515](https://insights.sbomify.com/CVE-2026-35515/): @nestjs/core Improperly Neutralizes Special Elements in Output Used by a Downstream Component ('Injection') (medium 6.3)
- [CVE-2024-29409](https://insights.sbomify.com/CVE-2024-29409/): nest allows a remote attacker to execute arbitrary code via the Content-Type header (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69211 and fix it if it is affected.

What it is: CVE-2025-69211 is a medium-severity authentication bypass vulnerability in nestjs nest, published on 29 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69211 exists.

Affected packages and fixed versions:
- @nestjs/platform-fastify (npm): affected all versions; fixed in 11.1.11
- @nestjs/platform-fastify (npm): affected all versions; fixed in 11.1.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69211/ (Markdown: https://insights.sbomify.com/CVE-2025-69211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69211
- OSV: https://osv.dev/vulnerability/CVE-2025-69211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69211/
Summaries are generated and may contain mistakes; the official description above is the record.
