# CVE-2025-69219: Apache Airflow Providers Http has Unsafe Pickle Deserializatio leading to RCE via HttpOperator

> An attacker with database access can trigger remote code execution on the Triggerer via unsafe pickle deserialization in the HTTP provider.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2026
- **Updated:** 10 Mar 2026
- **Also known as:** CLEANSTART-2026-KP40692, CLSA-2026-1779670115, ECHO-7803-48c3-bfab, GHSA-9r5j-7r2x-rv4g, MINI-8h9q-4vj5-gqmq, MINI-mxj3-mvfm-qmrm, PYSEC-2026-2367

## What is CVE-2025-69219?

CVE-2025-69219 is a high-severity unsafe deserialization vulnerability in Apache Airflow Providers Http, published on 9 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A user with access to the DB could craft a database entry that would result in executing code on Triggerer - which gives anyone who have access to DB the same permissions as Dag Author. Since direct DB access is not usual and recommended for Airflow, the likelihood of it making any damage is low.

You should upgrade to version 6.0.0 of the provider to avoid even that risk.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources)

## Which versions are affected by CVE-2025-69219?

3 open source packages ship an affected version, including apache-airflow-providers-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-http` | PyPI | All versions | 6.0.0 |
| `apache-airflow-providers-http` | PyPI | All versions | 6.0.0 |
| `apache-airflow-providers-http` | PyPI | All versions | 6.0.0 |

Products: Apache Airflow Providers Http.

## How do I fix CVE-2025-69219?

Upgrade apache-airflow-providers-http to 6.0.0 or later.

## Is CVE-2025-69219 being exploited?

There is no known exploitation of CVE-2025-69219 in the wild and no public exploit code.

Public exploit code:

- https://github.com/sak110/CVE-2025-69219 (github_poc): https://github.com/sak110/CVE-2025-69219
- cve-2025-69219 (github_poc): https://github.com/ahmetartuc/poc-cve-2025-69219

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69219 and fix it if it is affected.

What it is: CVE-2025-69219 is a high-severity unsafe deserialization vulnerability in Apache Airflow Providers Http, published on 9 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-69219 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-http (PyPI): affected all versions; fixed in 6.0.0
- apache-airflow-providers-http (PyPI): affected all versions; fixed in 6.0.0
- apache-airflow-providers-http (PyPI): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69219/ (Markdown: https://insights.sbomify.com/CVE-2025-69219/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69219
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69219
- OSV: https://osv.dev/vulnerability/CVE-2025-69219

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69219/
Summaries are generated and may contain mistakes; the official description above is the record.
