# CVE-2025-69223: AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb

> Attackers can cause denial of service by sending compressed requests that exhaust server memory via the auto_decompress feature.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2026
- **Updated:** 18 Sep 2026
- **Also known as:** AZL-73494, AZL-73517, CLEANSTART-2026-OU64383, CLEANSTART-2026-WQ53344, CLSA-2026-1790250538, CLSA-2026-1790342075, CLSA-2026-1790670795, CLSA-2026-1790685278, DEBIAN-CVE-2025-69223, ECHO-ceba-eb70-4da5, GHSA-6mq8-rvhq-8wgg, MINI-cfvp-9rfv-8733, MINI-jcxv-96hm-4q49, MINI-r3jc-5rr9-2q8h, PYSEC-2026-1101, ROOT-APP-PYPI-CVE-2025-69223, UBUNTU-CVE-2025-69223

## What is CVE-2025-69223?

CVE-2025-69223 is a high-severity denial of service vulnerability in aio-libs aiohttp, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Versions 3.13.2 and below allow a zip bomb to be used to execute a DoS against the AIOHTTP server. An attacker may be able to send a compressed request that when decompressed by AIOHTTP could exhaust the host's memory. This issue is fixed in version 3.13.3.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2025-69223?

3 open source packages ship an affected version, including aiohttp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | All versions | 3.13.3 |
| `aiohttp` | PyPI | All versions | 3.13.3 |
| `aiohttp` | PyPI | All versions | 3.13.3 |

Products: Aiohttp Aiohttp.

## How do I fix CVE-2025-69223?

Upgrade aiohttp to 3.13.3 or later.

## Is CVE-2025-69223 being exploited?

There is no known exploitation of CVE-2025-69223 in the wild and no public exploit code.

## Other vulnerabilities in aio-libs aiohttp

- [CVE-2024-52303](https://insights.sbomify.com/CVE-2024-52303/): aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method (high 8.7)
- [CVE-2024-30251](https://insights.sbomify.com/CVE-2024-30251/): Denial of service when trying to parse malformed POST requests in aiohttp (high 7.5)
- [CVE-2023-49081](https://insights.sbomify.com/CVE-2023-49081/): aiohttp's ClientSession is vulnerable to CRLF injection via version (high 7.2)
- [CVE-2026-22815](https://insights.sbomify.com/CVE-2026-22815/): AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers (medium 6.9)
- [CVE-2026-54273](https://insights.sbomify.com/CVE-2026-54273/): AIOHTTP: HTTP/1 Pipelined Requests Queue Without Limit (medium 6.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69223 and fix it if it is affected.

What it is: CVE-2025-69223 is a high-severity denial of service vulnerability in aio-libs aiohttp, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-69223 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected all versions; fixed in 3.13.3
- aiohttp (PyPI): affected all versions; fixed in 3.13.3
- aiohttp (PyPI): affected all versions; fixed in 3.13.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69223/ (Markdown: https://insights.sbomify.com/CVE-2025-69223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69223
- OSV: https://osv.dev/vulnerability/CVE-2025-69223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69223/
Summaries are generated and may contain mistakes; the official description above is the record.
