# CVE-2025-69227: AIOHTTP vulnerable to DoS when bypassing asserts

> Attackers can cause a denial of service via infinite loop in aiohttp when Python optimizations are enabled and POST bodies are processed.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2026
- **Updated:** 6 Jan 2026
- **Also known as:** AZL-73506, AZL-73529, CLEANSTART-2026-LP35415, DEBIAN-CVE-2025-69227, ECHO-0555-db3f-4098, GHSA-jj3x-wxrx-4x23, MINI-hfwx-cf9p-rhf4, MINI-w8rq-jv6v-v427, PYSEC-2026-1107, ROOT-APP-PYPI-CVE-2025-69227, UBUNTU-CVE-2025-69227

## What is CVE-2025-69227?

CVE-2025-69227 is a medium-severity denial of service vulnerability in aio-libs aiohttp, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Versions 3.13.2 and below allow for an infinite loop to occur when assert statements are bypassed, resulting in a DoS attack when processing a POST body. If optimizations are enabled (-O or PYTHONOPTIMIZE=1), and the application includes a handler that uses the Request.post() method, then an attacker may be able to execute a DoS attack with a specially crafted message. This issue is fixed in version 3.13.3.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2025-69227?

3 open source packages ship an affected version, including aiohttp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | All versions | 3.13.3 |
| `aiohttp` | PyPI | All versions | 3.13.3 |
| `aiohttp` | PyPI | All versions | 3.13.3 |

Products: Aiohttp Aiohttp.

## How do I fix CVE-2025-69227?

Upgrade aiohttp to 3.13.3 or later.

## Is CVE-2025-69227 being exploited?

There is no known exploitation of CVE-2025-69227 in the wild and no public exploit code.

## Other vulnerabilities in aio-libs aiohttp

- [CVE-2024-52303](https://insights.sbomify.com/CVE-2024-52303/): aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method (high 8.7)
- [CVE-2025-69223](https://insights.sbomify.com/CVE-2025-69223/): AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb (high 7.5)
- [CVE-2024-30251](https://insights.sbomify.com/CVE-2024-30251/): Denial of service when trying to parse malformed POST requests in aiohttp (high 7.5)
- [CVE-2023-49081](https://insights.sbomify.com/CVE-2023-49081/): aiohttp's ClientSession is vulnerable to CRLF injection via version (high 7.2)
- [CVE-2026-22815](https://insights.sbomify.com/CVE-2026-22815/): AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69227 and fix it if it is affected.

What it is: CVE-2025-69227 is a medium-severity denial of service vulnerability in aio-libs aiohttp, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-69227 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected all versions; fixed in 3.13.3
- aiohttp (PyPI): affected all versions; fixed in 3.13.3
- aiohttp (PyPI): affected all versions; fixed in 3.13.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69227/ (Markdown: https://insights.sbomify.com/CVE-2025-69227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69227
- OSV: https://osv.dev/vulnerability/CVE-2025-69227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69227/
Summaries are generated and may contain mistakes; the official description above is the record.
