# CVE-2025-69228: AIOHTTP vulnerable to denial of service through large payloads

> Attackers can exhaust server memory via large payloads, causing denial of service in applications using aiohttp's Request.post() method.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2026
- **Updated:** 6 Jan 2026
- **Also known as:** AZL-73509, AZL-73532, CLEANSTART-2026-NJ64514, CLEANSTART-2026-UK95616, DEBIAN-CVE-2025-69228, ECHO-ec36-3803-b3eb, GHSA-6jhg-hg63-jvvf, MINI-2r3g-j943-wwvc, MINI-rg7j-h28p-h327, PYSEC-2026-1100, ROOT-APP-PYPI-CVE-2025-69228, UBUNTU-CVE-2025-69228

## What is CVE-2025-69228?

CVE-2025-69228 is a medium-severity denial of service vulnerability in aio-libs aiohttp, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Versions 3.13.2 and below allow a request to be crafted in such a way that an AIOHTTP server's memory fills up uncontrollably during processing. If an application includes a handler that uses the Request.post() method, an attacker may be able to freeze the server by exhausting the memory. This issue is fixed in version 3.13.3.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-69228?

3 open source packages ship an affected version, including aiohttp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | All versions | 3.13.3 |
| `aiohttp` | PyPI | All versions | 3.13.3 |
| `aiohttp` | PyPI | All versions | 3.13.3 |

Products: Aiohttp Aiohttp.

## How do I fix CVE-2025-69228?

Upgrade aiohttp to 3.13.3 or later.

## Is CVE-2025-69228 being exploited?

There is no known exploitation of CVE-2025-69228 in the wild and no public exploit code.

## Other vulnerabilities in aio-libs aiohttp

- [CVE-2024-52303](https://insights.sbomify.com/CVE-2024-52303/): aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method (high 8.7)
- [CVE-2025-69223](https://insights.sbomify.com/CVE-2025-69223/): AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb (high 7.5)
- [CVE-2024-30251](https://insights.sbomify.com/CVE-2024-30251/): Denial of service when trying to parse malformed POST requests in aiohttp (high 7.5)
- [CVE-2023-49081](https://insights.sbomify.com/CVE-2023-49081/): aiohttp's ClientSession is vulnerable to CRLF injection via version (high 7.2)
- [CVE-2026-22815](https://insights.sbomify.com/CVE-2026-22815/): AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69228 and fix it if it is affected.

What it is: CVE-2025-69228 is a medium-severity denial of service vulnerability in aio-libs aiohttp, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-69228 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected all versions; fixed in 3.13.3
- aiohttp (PyPI): affected all versions; fixed in 3.13.3
- aiohttp (PyPI): affected all versions; fixed in 3.13.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69228/ (Markdown: https://insights.sbomify.com/CVE-2025-69228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69228
- OSV: https://osv.dev/vulnerability/CVE-2025-69228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69228/
Summaries are generated and may contain mistakes; the official description above is the record.
