CVE-2025-69233 Apache CloudStack: Domain/account resources limits not honored

Medium 6.5 Published Updated

Attackers can bypass resource limits via race conditions to exhaust infrastructure resources, causing denial of service in Apache CloudStack.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-69233?

CVE-2025-69233 is a medium-severity vulnerability in Apache Cloudstack, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Due to multiple time-of-check time-of-use race conditions in the resource count check and increment logic, as well as missing validations, users of the platform are able to exceed the allocation limits configured for their accounts/domains. This can be used by an attacker to degrade the infrastructure's resources and lead to denial of service conditions.

Users are recommended to upgrade to Apache CloudStack versions 4.20.3.0 or 4.22.0.1, or later, which fixes this issue.

Weakness: CWE-770, CWE-367

Which versions are affected by CVE-2025-69233?

It affects 1 product.

Products include Apache Cloudstack.

How do I fix CVE-2025-69233?

No fix has been published for CVE-2025-69233 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-69233 being exploited?

There is no known exploitation of CVE-2025-69233 in the wild and no public exploit code.

All Apache Cloudstack vulnerabilities

Sources

Also known as GHSA-jj3r-fj56-xf97.

Is CVE-2025-69233 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free