# CVE-2025-69256: serverless MCP Server vulnerable to command injection in list-projects tool

> Attackers can execute arbitrary system commands via the experimental MCP server's list-projects tool, leading to remote code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Dec 2025
- **Updated:** 30 Dec 2025
- **Also known as:** GHSA-rwc2-f344-q6w6

## What is CVE-2025-69256?

CVE-2025-69256 is a high-severity command injection vulnerability in serverless, published on 30 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Serverless Framework is a framework for using AWS Lambda and other managed cloud services to build applications. Starting in version 4.29.0 and prior to version 4.29.3, a command injection vulnerability exists in the Serverless Framework's built-in MCP server package (@serverless/mcp). This vulnerability only affects users of the experimental MCP server feature (serverless mcp), which represents less than 0.1% of Serverless Framework users. The core Serverless Framework CLI and deployment functionality are not affected. The vulnerability is caused by the unsanitized use of input parameters within a call to `child_process.exec`, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (`|`, `>`, `&&`, etc.). Version 4.29.3 fixes the issue.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-69256?

2 open source packages ship an affected version, including serverless. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `serverless` | npm | From 4.29.0 | 4.29.3 |
| `serverless` | npm | From 4.29.0 | 4.29.3 |

Products: Serverless Serverless.

## How do I fix CVE-2025-69256?

Upgrade serverless to 4.29.3 or later.

## Is CVE-2025-69256 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69256 exists.

Public exploit code:

- Serverless Framework MCP Server (CVE-2025-69256) Base Score: 9.4/10 → CTT Enhanced Score: 9.9/10  A critical command injection vulnerability in Serverless Framework's MCP (Model Context Protocol) server enhanced with CTT temporal resonance for unprecedented exploitation reliability and evasion. (github_poc): https://github.com/SimoesCTT/CTT-Serverless-RCE-v1.0---Convergent-Time-Theory-Enhanced-MCP-Exploit
- Layer-2 supply-chain hardening for MCP servers — Ed25519-signed tool manifests, runtime spawn-attestation, default-deny argument sanitizer. Defends against marketplace-poisoning + CVE-2025-69256 + CVE-2025-61591. (github_poc): https://github.com/studiomeyer-io/mcp-server-attestation
- Defense-in-depth bundle for MCP stdio servers: drop-in guardExec/guardSpawn wrappers, AST audit CLI, reference MCP server. Closes the Ox-Security 200k-server stdio-RCE class (LiteLLM CVE-2025-69256). MIT, TypeScript, Node >= 20. (github_poc): https://github.com/studiomeyer-io/mcp-stdio-shellguard

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69256 and fix it if it is affected.

What it is: CVE-2025-69256 is a high-severity command injection vulnerability in serverless, published on 30 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69256 exists.

Affected packages and fixed versions:
- serverless (npm): affected from 4.29.0; fixed in 4.29.3
- serverless (npm): affected from 4.29.0; fixed in 4.29.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69256/ (Markdown: https://insights.sbomify.com/CVE-2025-69256/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69256
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69256
- OSV: https://osv.dev/vulnerability/CVE-2025-69256

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69256/
Summaries are generated and may contain mistakes; the official description above is the record.
