{"answers":{"affected":"3 open source packages ship an affected version, including theshit.","exploited":"There is no known exploitation of CVE-2025-69257 in the wild and no public exploit code.","fix":"Upgrade theshit to 0.1.1 or later.","what":"CVE-2025-69257 is a medium-severity vulnerability in AsfhtgkDavid theshit, published on 30 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-69257 and fix it if it is affected.\n\nWhat it is: CVE-2025-69257 is a medium-severity vulnerability in AsfhtgkDavid theshit, published on 30 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-69257 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- theshit (crates.io): affected all versions; fixed in 0.1.1\n- theshit (crates.io): affected all versions; fixed in 0.1.1\n- theshit (crates.io): affected from 0.0.0-0; fixed in 0.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-69257/ (Markdown: https://insights.sbomify.com/CVE-2025-69257/index.md)","id":"CVE-2025-69257","markdown":"https://insights.sbomify.com/CVE-2025-69257/index.md","name":"CVE-2025-69257","record":{"aliases":["GHSA-95qg-89c2-w5hj","RUSTSEC-2025-0139"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Shell command fixer CLI","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges to root by injecting malicious Python code into user-owned configuration files when the tool runs with elevated privileges.","user_interaction":"required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"},{"id":"CWE-284","name":"Improper Access Control"},{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"theshit is a command-line utility that automatically detects and fixes common mistakes in shell commands. Prior to version 0.1.1, the application loads custom Python rules and configuration files from user-writable locations (e.g., `~/.config/theshit/`) without validating ownership or permissions when executed with elevated privileges. If the tool is invoked with `sudo` or otherwise runs with an effective UID of root, it continues to trust configuration files originating from the unprivileged user's environment. This allows a local attacker to inject arbitrary Python code via a malicious rule or configuration file, which is then executed with root privileges. Any system where this tool is executed with elevated privileges is affected. In environments where the tool is permitted to run via `sudo` without a password (`NOPASSWD`), a local unprivileged user can escalate privileges to root without additional interaction. The issue has been fixed in version 0.1.1. The patch introduces strict ownership and permission checks for all configuration files and custom rules. The application now enforces that rules are only loaded if they are owned by the effective user executing the tool. When executed with elevated privileges (`EUID=0`), the application refuses to load any files that are not owned by root or that are writable by non-root users. When executed as a non-root user, it similarly refuses to load rules owned by other users. This prevents both vertical and horizontal privilege escalation via execution of untrusted code. If upgrading is not possible, users should avoid executing the application with `sudo` or as the root user. As a temporary mitigation, ensure that directories containing custom rules and configuration files are owned by root and are not writable by non-root users. Administrators may also audit existing custom rules before running the tool with elevated privileges.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"theshit vulnerable to unsafe loading of user-owned Python rules when running as root.","id":"CVE-2025-69257","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Code injection in Trend Micro Apex Central","id":"CVE-2025-69258"},"packages":[{"ecosystem":"crates.io","fixed":["0.1.1"],"introduced":["0"],"last_affected":[],"package":"theshit","purl":null,"source":"GHSA-95qg-89c2-w5hj"},{"ecosystem":"crates.io","fixed":["0.1.1"],"introduced":["0"],"last_affected":[],"package":"theshit","purl":"pkg:cargo/theshit","source":"GHSA-95qg-89c2-w5hj"},{"ecosystem":"crates.io","fixed":["0.1.1"],"introduced":["0.0.0-0"],"last_affected":[],"package":"theshit","purl":"pkg:cargo/theshit","source":"RUSTSEC-2025-0139"}],"prev":{"headline":"serverless MCP Server vulnerable to command injection in list-projects tool","id":"CVE-2025-69256"},"products":["theshit"],"published":"2025-12-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-30","vendors":["AsfhtgkDavid"]},"summary":"Local attackers can escalate privileges to root by injecting malicious Python code into user-owned configuration files when the tool runs with elevated privileges.","url":"https://insights.sbomify.com/CVE-2025-69257/"}