# CVE-2025-69257: theshit vulnerable to unsafe loading of user-owned Python rules when running as root.

> Local attackers can escalate privileges to root by injecting malicious Python code into user-owned configuration files when the tool runs with elevated privileges.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Dec 2025
- **Updated:** 30 Dec 2025
- **Also known as:** GHSA-95qg-89c2-w5hj, RUSTSEC-2025-0139

## What is CVE-2025-69257?

CVE-2025-69257 is a medium-severity vulnerability in AsfhtgkDavid theshit, published on 30 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

theshit is a command-line utility that automatically detects and fixes common mistakes in shell commands. Prior to version 0.1.1, the application loads custom Python rules and configuration files from user-writable locations (e.g., `~/.config/theshit/`) without validating ownership or permissions when executed with elevated privileges. If the tool is invoked with `sudo` or otherwise runs with an effective UID of root, it continues to trust configuration files originating from the unprivileged user's environment. This allows a local attacker to inject arbitrary Python code via a malicious rule or configuration file, which is then executed with root privileges. Any system where this tool is executed with elevated privileges is affected. In environments where the tool is permitted to run via `sudo` without a password (`NOPASSWD`), a local unprivileged user can escalate privileges to root without additional interaction. The issue has been fixed in version 0.1.1. The patch introduces strict ownership and permission checks for all configuration files and custom rules. The application now enforces that rules are only loaded if they are owned by the effective user executing the tool. When executed with elevated privileges (`EUID=0`), the application refuses to load any files that are not owned by root or that are writable by non-root users. When executed as a non-root user, it similarly refuses to load rules owned by other users. This prevents both vertical and horizontal privilege escalation via execution of untrusted code. If upgrading is not possible, users should avoid executing the application with `sudo` or as the root user. As a temporary mitigation, ensure that directories containing custom rules and configuration files are owned by root and are not writable by non-root users. Administrators may also audit existing custom rules before running the tool with elevated privileges.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-284 (Improper Access Control), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2025-69257?

3 open source packages ship an affected version, including theshit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `theshit` | crates.io | All versions | 0.1.1 |
| `theshit` | crates.io | All versions | 0.1.1 |
| `theshit` | crates.io | From 0.0.0-0 | 0.1.1 |

## How do I fix CVE-2025-69257?

Upgrade theshit to 0.1.1 or later.

## Is CVE-2025-69257 being exploited?

There is no known exploitation of CVE-2025-69257 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69257 and fix it if it is affected.

What it is: CVE-2025-69257 is a medium-severity vulnerability in AsfhtgkDavid theshit, published on 30 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-69257 in the wild and no public exploit code.

Affected packages and fixed versions:
- theshit (crates.io): affected all versions; fixed in 0.1.1
- theshit (crates.io): affected all versions; fixed in 0.1.1
- theshit (crates.io): affected from 0.0.0-0; fixed in 0.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69257/ (Markdown: https://insights.sbomify.com/CVE-2025-69257/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69257
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69257
- OSV: https://osv.dev/vulnerability/CVE-2025-69257

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69257/
Summaries are generated and may contain mistakes; the official description above is the record.
