CVE-2025-69262 pnpm vulnerable to Command Injection via environment variable substitution

High 7.6 Published Updated

Attackers controlling environment variables can achieve remote code execution in build environments using pnpm with tokenHelper settings.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-69262?

CVE-2025-69262 is a high-severity command injection vulnerability in pnpm, published on 7 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.

Weakness: CWE-94, CWE-78

Which versions are affected by CVE-2025-69262?

2 open source packages ship an affected version, including pnpm. It affects 1 product.

PackageAffectedFixed in
pnpm npmFrom 6.25.010.27.0
pnpm npmFrom 6.25.010.27.0

Products include Pnpm Pnpm.

How do I fix CVE-2025-69262?

Upgrade pnpm to 10.27.0 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-69262 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69262 exists.

Sources

Also known as GHSA-2phv-j68v-wwqx, MINI-4vx7-x8h2-h48v.

Is CVE-2025-69262 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free