# CVE-2025-69262: pnpm vulnerable to Command Injection via environment variable substitution

> Attackers controlling environment variables can achieve remote code execution in build environments using pnpm with tokenHelper settings.

- **Severity:** High 7.6 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-2phv-j68v-wwqx, MINI-4vx7-x8h2-h48v

## What is CVE-2025-69262?

CVE-2025-69262 is a high-severity command injection vulnerability in pnpm, published on 7 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-69262?

2 open source packages ship an affected version, including pnpm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pnpm` | npm | From 6.25.0 | 10.27.0 |
| `pnpm` | npm | From 6.25.0 | 10.27.0 |

Products: Pnpm Pnpm.

## How do I fix CVE-2025-69262?

Upgrade pnpm to 10.27.0 or later.

## Is CVE-2025-69262 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69262 exists.

## Other vulnerabilities in pnpm

- [CVE-2026-50016](https://insights.sbomify.com/CVE-2026-50016/): pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement (high 8.8)
- [CVE-2026-55698](https://insights.sbomify.com/CVE-2026-55698/): pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes (high 8.8)
- [CVE-2025-69264](https://insights.sbomify.com/CVE-2025-69264/): pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default" (high 8.8)
- [CVE-2022-26183](https://insights.sbomify.com/CVE-2022-26183/): Untrusted Search Path in PNPM (high 8.8)
- [CVE-2026-59195](https://insights.sbomify.com/CVE-2026-59195/): pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69262 and fix it if it is affected.

What it is: CVE-2025-69262 is a high-severity command injection vulnerability in pnpm, published on 7 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69262 exists.

Affected packages and fixed versions:
- pnpm (npm): affected from 6.25.0; fixed in 10.27.0
- pnpm (npm): affected from 6.25.0; fixed in 10.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69262/ (Markdown: https://insights.sbomify.com/CVE-2025-69262/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69262
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69262
- OSV: https://osv.dev/vulnerability/CVE-2025-69262

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69262/
Summaries are generated and may contain mistakes; the official description above is the record.
