CVE-2025-69263 pnpm Lockfile Integrity Bypass Allows Remote Dynamic Dependencies

High 7.5 Published Updated

Attackers can serve malicious code via HTTP tarball dependencies because pnpm lockfiles lack integrity hashes, compromising supply chain security.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-69263?

CVE-2025-69263 is a high-severity vulnerability in pnpm, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

pnpm is a package manager. Versions 10.26.2 and below store HTTP tarball dependencies (and git-hosted tarballs) in the lockfile without integrity hashes. This allows the remote server to serve different content on each install, even when a lockfile is committed. An attacker who publishes a package with an HTTP tarball dependency can serve different code to different users or CI/CD environments. The attack requires the victim to install a package that has an HTTP/git tarball in its dependency tree. The victim's lockfile provides no protection. This issue is fixed in version 10.26.0.

Weakness: CWE-494

Which versions are affected by CVE-2025-69263?

2 open source packages ship an affected version, including pnpm. It affects 1 product.

PackageAffectedFixed in
pnpm npmAll versions10.26.0
pnpm npmAll versions10.26.0

Products include Pnpm Pnpm.

How do I fix CVE-2025-69263?

Upgrade pnpm to 10.26.0 or later.

Is CVE-2025-69263 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69263 exists.

Sources

Also known as GHSA-7vhp-vf5g-r2fw, MINI-gp4p-jc2h-52v6.

Is CVE-2025-69263 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free